Bug 249419 - graphics/gnome-video-effects: fails to install after update to 0.5.0 (pkg-static: Unable to access file /usr/ports/graphics/gnome-video-effects/work/stage/usr/local/libdata/pkgconfig/gnome-video-effects.pc:No such file or directory)
Summary: graphics/gnome-video-effects: fails to install after update to 0.5.0 (pkg-sta...
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: amd64 Any
: --- Affects Some People
Assignee: freebsd-gnome (Nobody)
URL:
Keywords: easy, regression
: 249421 (view as bug list)
Depends on:
Blocks: 249424
  Show dependency treegraph
 
Reported: 2020-09-18 07:26 UTC by VVD
Modified: 2020-09-18 20:26 UTC (History)
3 users (show)

See Also:
bugzilla: maintainer-feedback? (gnome)


Attachments
patch to get the .pc file into the right location (381 bytes, patch)
2020-09-18 09:08 UTC, Matthias Andree
mandree: maintainer-approval? (gnome)
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description VVD 2020-09-18 07:26:50 UTC
12.1-p10 amd64.

===>  Installing for gnome-video-effects-0.5.0
===>  Checking if gnome-video-effects is already installed
===>   Registering installation for gnome-video-effects-0.5.0 as automatic
pkg-static: Unable to access file /tmp/work/usr/ports/graphics/gnome-video-effects/work/stage/usr/local/libdata/pkgconfig/gnome-video-effects.pc:No such file or directory
*** Error code 74

It exist, but in another directory:
# find /tmp/work/usr/ports/graphics/gnome-video-effects/work -name '*.pc'
/tmp/work/usr/ports/graphics/gnome-video-effects/work/gnome-video-effects-0.5.0/_build/gnome-video-effects.pc
/tmp/work/usr/ports/graphics/gnome-video-effects/work/stage/usr/local/share/pkgconfig/gnome-video-effects.pc
Comment 1 Matthias Andree freebsd_committer 2020-09-18 08:49:47 UTC
*** Bug 249421 has been marked as a duplicate of this bug. ***
Comment 2 Matthias Andree freebsd_committer 2020-09-18 08:51:36 UTC
see duplicate PR for check-plist output
Comment 3 Matthias Andree freebsd_committer 2020-09-18 09:08:18 UTC
Created attachment 218043 [details]
patch to get the .pc file into the right location
Comment 4 Matthias Andree freebsd_committer 2020-09-18 09:09:29 UTC
Remember to bump PORTREVISION if applying my patch
Comment 5 commit-hook freebsd_committer 2020-09-18 20:26:12 UTC
A commit references this bug:

Author: bapt
Date: Fri Sep 18 20:25:33 UTC 2020
New revision: 548902
URL: https://svnweb.freebsd.org/changeset/ports/548902

Log:
  Add patch which I forgot to svn add during previous commit

  PR:		249419
  Reported by:	vvd@unislabs.com

Changes:
  head/graphics/gnome-video-effects/files/
  head/graphics/gnome-video-effects/files/patch-meson.build