Bug 249429 - x11-themes/gnome-themes-extra: PLIST incomplete/avoid messing up STAGEDIR
Summary: x11-themes/gnome-themes-extra: PLIST incomplete/avoid messing up STAGEDIR
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: freebsd-gnome (Nobody)
URL:
Keywords: easy, regression
: 236892 (view as bug list)
Depends on:
Blocks: 249424
  Show dependency treegraph
 
Reported: 2020-09-18 12:19 UTC by Matthias Andree
Modified: 2020-10-04 08:20 UTC (History)
1 user (show)

See Also:
mandree: maintainer-feedback-


Attachments
proposal to fix plist issue (1.12 KB, patch)
2020-09-19 07:37 UTC, Matthias Andree
mandree: maintainer-approval? (gnome)
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Matthias Andree freebsd_committer 2020-09-18 12:19:03 UTC
[00:03:39] ===> Parsing plist
[00:03:41] ===> Checking for items in STAGEDIR missing from pkg-plist
[00:03:41] Error: Orphaned: @dir share/locale/an/LC_MESSAGES
[00:03:41] Error: Orphaned: @dir share/locale/as/LC_MESSAGES
[00:03:41] Error: Orphaned: @dir share/locale/bn_IN/LC_MESSAGES
[00:03:41] Error: Orphaned: @dir share/locale/ca@valencia/LC_MESSAGES
[00:03:41] Error: Orphaned: @dir share/locale/fur/LC_MESSAGES
[00:03:41] Error: Orphaned: @dir share/locale/fy/LC_MESSAGES
[00:03:41] Error: Orphaned: @dir share/locale/gd/LC_MESSAGES
[00:03:41] Error: Orphaned: @dir share/locale/kk/LC_MESSAGES
[00:03:41] Error: Orphaned: @dir share/locale/km/LC_MESSAGES
[00:03:41] Error: Orphaned: @dir share/locale/ln/LC_MESSAGES
[00:03:41] Error: Orphaned: @dir share/locale/mr/LC_MESSAGES
[00:03:41] Error: Orphaned: @dir share/locale/oc/LC_MESSAGES
[00:03:41] Error: Orphaned: @dir share/locale/sr@latin/LC_MESSAGES
[00:03:41] Error: Orphaned: @dir share/locale/te/LC_MESSAGES
[00:03:41] Error: Orphaned: @dir share/locale/ug/LC_MESSAGES
[00:03:41] Error: Orphaned: @dir share/locale/uz@cyrillic/LC_MESSAGES
[00:03:41] Error: Orphaned: @dir share/locale/zh_HK/LC_MESSAGES
[00:03:41] ===> Checking for items in pkg-plist which are not in STAGEDIR
[00:03:41] ===> Error: Plist issues found.
[00:03:41] *** Error code 1
Comment 1 Matthias Andree freebsd_committer 2020-09-19 07:37:12 UTC
Created attachment 218066 [details]
proposal to fix plist issue

since the original upstream package intends to NOT install locale files, just patch po out of SUBDIR to prevent the install/uninstall dance, where the latter remains incomplete because it does not remove directories, and consequently upsets our ports system's check-plist.
Comment 2 commit-hook freebsd_committer 2020-10-04 08:19:55 UTC
A commit references this bug:

Author: mandree
Date: Sun Oct  4 08:19:24 UTC 2020
New revision: 551364
URL: https://svnweb.freebsd.org/changeset/ports/551364

Log:
  x11-themes/gnome-themes-extra: avoid messing up STAGEDIR/plist failure

  PR:		249429
  Approved by:	freebsd-gnome (maintainer timeout, 15d)

Changes:
  head/x11-themes/gnome-themes-extra/Makefile
  head/x11-themes/gnome-themes-extra/files/
  head/x11-themes/gnome-themes-extra/files/patch-Makefile.in
Comment 3 Matthias Andree freebsd_committer 2020-10-04 08:20:13 UTC
*** Bug 236892 has been marked as a duplicate of this bug. ***