Bug 249431 - make buildworld is failed on stand/libsa
Summary: make buildworld is failed on stand/libsa
Status: Closed Not A Bug
Alias: None
Product: Base System
Classification: Unclassified
Component: bin (show other bugs)
Version: CURRENT
Hardware: amd64 Any
: --- Affects Many People
Assignee: freebsd-bugs (Nobody)
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2020-09-18 13:10 UTC by Alexander Mishin
Modified: 2020-09-18 16:44 UTC (History)
0 users

See Also:


Attachments
Fix for stand/libsa (473 bytes, patch)
2020-09-18 13:10 UTC, Alexander Mishin
no flags Details | Diff
patch_stand_libsa.diff (473 bytes, patch)
2020-09-18 13:19 UTC, Alexander Mishin
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Alexander Mishin 2020-09-18 13:10:34 UTC
Created attachment 218051 [details]
Fix for stand/libsa

FreeBSD 13.0-CURRENT updated to revision 365879.

Building the world is failed:

===> stand/libsa (all)
===> kerberos5/libexec/kpasswdd (all)
cp: /dev/null: Invalid argument
--- beforedepend ---
*** [beforedepend] Error code 1

make[4]: stopped in /usr/src/stand/libsa
--- all_subdir_stand ---
--- all_subdir_secure/lib/libcrypto ---
--- all_subdir_secure ---
--- all_subdir_lib/libc ---
--- all_subdir_lib ---
--- xz_make ---
*** [xz_make] Error code 2

make[5]: stopped in /usr/obj/usr/src/amd64.amd64/rescue/rescue
--- all_subdir_rescue/rescue ---
--- all_subdir_rescue ---
--- all_subdir_share/examples/tests/tests/googletest ---
--- all_subdir_share ---
--- all_subdir_kerberos5/libexec/kpasswdd ---
--- all_subdir_kerberos5 ---
--- everything ---
--- buildworld ---

Quick and dirty patch is attached.
Comment 1 Alexander Mishin 2020-09-18 13:19:45 UTC
Created attachment 218052 [details]
patch_stand_libsa.diff
Comment 2 xtouqh 2020-09-18 14:22:35 UTC
Not a bug per se, rather intermittent build issue, reported several times on current@ and in bugzilla.  See e.g. https://lists.freebsd.org/pipermail/freebsd-current/2020-September/077216.html for workaround.  See base r365643 for the fix.
Comment 3 Alexander Mishin 2020-09-18 16:44:23 UTC
Thanks