Bug 249448 - graphics/mesa-libs: conflicts with x11/nvidia-driver, x11/nvidia-driver-390 (/usr/local/lib/libGLESv1_CM.so)
Summary: graphics/mesa-libs: conflicts with x11/nvidia-driver, x11/nvidia-driver-390 (...
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: amd64 Any
: --- Affects Some People
Assignee: freebsd-x11 (Nobody)
URL:
Keywords:
: 249548 249975 (view as bug list)
Depends on:
Blocks:
 
Reported: 2020-09-19 11:15 UTC by VVD
Modified: 2020-09-29 06:14 UTC (History)
16 users (show)

See Also:


Attachments
Handle libGLESv1_CM.so (2.46 KB, patch)
2020-09-19 11:33 UTC, Emmanuel Vadot
no flags Details | Diff
v2 (2.86 KB, patch)
2020-09-19 11:35 UTC, Emmanuel Vadot
no flags Details | Diff
3rd time the charm ? (2.72 KB, patch)
2020-09-19 11:39 UTC, Emmanuel Vadot
manu: maintainer-approval+
Details | Diff
v4 (3.03 KB, patch)
2020-09-19 11:46 UTC, Emmanuel Vadot
no flags Details | Diff
v4 patch with nvidia-driver and linux-nvidia-libs updated to 450.66 (15.57 KB, patch)
2020-09-21 08:52 UTC, Tomoaki AOKI
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description VVD 2020-09-19 11:15:27 UTC
After this commit https://svnweb.freebsd.org/ports?view=revision&sortby=date&revision=548950 install conflicts:
===>  Installing for mesa-libs-19.0.8_3
===>  Checking if mesa-libs is already installed
===>   Registering installation for mesa-libs-19.0.8_3 as automatic
Installing mesa-libs-19.0.8_3...
pkg-static: mesa-libs-19.0.8_3 conflicts with nvidia-driver-390-390.138 (installs files into the same place).  Problematic file: /usr/local/lib/libGLESv1_CM.so
*** Error code 70
Comment 1 VVD 2020-09-19 11:16:40 UTC
12.1-p10 amd64.
Comment 2 Emmanuel Vadot freebsd_committer 2020-09-19 11:33:37 UTC
Created attachment 218072 [details]
Handle libGLESv1_CM.so
Comment 3 Emmanuel Vadot freebsd_committer 2020-09-19 11:35:08 UTC
Created attachment 218073 [details]
v2
Comment 4 Emmanuel Vadot freebsd_committer 2020-09-19 11:39:50 UTC
Created attachment 218074 [details]
3rd time the charm ?
Comment 5 Emmanuel Vadot freebsd_committer 2020-09-19 11:46:36 UTC
Created attachment 218075 [details]
v4
Comment 6 VVD 2020-09-19 13:06:12 UTC
graphics/mesa-libs, x11/nvidia-driver-340 and x11/nvidia-driver-390 build and work fine with this patch.
Comment 7 Craig Leres freebsd_committer 2020-09-20 01:47:52 UTC
This solves the conflict for me with x11/nvidia-driver. Like the reporter, I'm at 12.1-RELEASE-p10.
Comment 8 david 2020-09-20 02:28:41 UTC
I'm running stable/12:
FreeBSD g1-48.catwhisker.org 12.2-STABLE FreeBSD 12.2-STABLE #816 r365891M/365898: Sat Sep 19 03:50:24 PDT 2020     root@g1-55.catwhisker.org:/common/S1/obj/usr/src/amd64.amd64/sys/CANARY  amd64

I just reverted r548950 locally, which seems to work OK.
Comment 9 mvharding 2020-09-20 17:40:11 UTC
I applied the v4 patch to the x11/nvidia-driver port in my local poudriere system, and was able to install the generated nvidia-driver-440.100_1 package and get X11 working again with my nvidia card (12.1-RELEASE-p10 amd64).
Comment 10 Tomoaki AOKI 2020-09-21 08:52:38 UTC
Created attachment 218135 [details]
v4 patch with nvidia-driver and linux-nvidia-libs updated to 450.66

v4 patch with nvidia-driver and linux-nvidia-libs updated to 450.66.
Applicable on /usr/ports.

Possibly insufficient, as not checked newly-added files.

Note that libnvidia-fatbinaryloader.so.* are removed from linux-nvidia-libs at 450.57. See [1] for details.

[1] https://www.nvidia.com/Download/driverResults.aspx/162352
Comment 11 commit-hook freebsd_committer 2020-09-21 09:05:51 UTC
A commit references this bug:

Author: manu
Date: Mon Sep 21 09:05:05 UTC 2020
New revision: 549424
URL: https://svnweb.freebsd.org/changeset/ports/549424

Log:
  Fix nvidia-driver* after r548950

  Now that mesa include glesv1 lib, remove the nvidia generic named lib
  and add more entries in libmap.conf so the nvidia ones are used.

  PR:		249448
  Reported by:	VVD <vvd@unislabs.com>

Changes:
  head/x11/nvidia-driver/Makefile
  head/x11/nvidia-driver/files/nvidia.conf.in
  head/x11/nvidia-driver/pkg-plist
  head/x11/nvidia-driver-304/Makefile
  head/x11/nvidia-driver-340/Makefile
  head/x11/nvidia-driver-390/Makefile
Comment 12 Emmanuel Vadot freebsd_committer 2020-09-21 09:07:00 UTC
(In reply to Tomoaki AOKI from comment #10)

Please open a new PR for the update.
I'm not the maintainer and I was only interested in fixing my mistake.
Comment 13 Tomoaki AOKI 2020-09-21 11:30:16 UTC
(In reply to Emmanuel Vadot from comment #12)

Done as Bug 249505 [patch]x11/nvidia-driver and x11/linux-nvidia-libs.
Comment 14 Niclas Zeising freebsd_committer 2020-09-23 15:13:16 UTC
*** Bug 249548 has been marked as a duplicate of this bug. ***
Comment 15 Niclas Zeising freebsd_committer 2020-09-29 06:14:20 UTC
*** Bug 249975 has been marked as a duplicate of this bug. ***