Bug 249466 - net-mgmt/unifi6: New port
Summary: net-mgmt/unifi6: New port
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: Mikael Urankar
URL: https://community.ui.com/releases/Uni...
Keywords:
Depends on:
Blocks:
 
Reported: 2020-09-19 22:19 UTC by Juraj Lutter
Modified: 2020-10-06 18:40 UTC (History)
5 users (show)

See Also:


Attachments
net-mgmt/unifi6: Diff from net-mgmt/unifi5 (3.93 KB, patch)
2020-09-19 22:19 UTC, Juraj Lutter
juraj: maintainer-approval+
Details | Diff
unifi6 full diff (5.48 KB, patch)
2020-09-19 22:19 UTC, Juraj Lutter
juraj: maintainer-approval+
Details | Diff
net-mgmt/unifi6: shar of port (17.07 KB, text/plain)
2020-09-19 22:20 UTC, Juraj Lutter
juraj: maintainer-approval+
Details
net-mgmt/unifi6: shar of port (17.07 KB, text/plain)
2020-09-25 17:36 UTC, Juraj Lutter
juraj: maintainer-approval+
Details
net-mgmt/unifi6: Update to 6.0.23 (5.48 KB, patch)
2020-09-25 17:36 UTC, Juraj Lutter
juraj: maintainer-approval+
Details | Diff
net-mgmt/unifi6: Diff from net-mgmt/unifi5 (4.00 KB, patch)
2020-09-25 17:38 UTC, Juraj Lutter
juraj: maintainer-approval+
Details | Diff
net-mgmt/unifi6: Update to 6.0.23 (5.45 KB, patch)
2020-10-03 10:54 UTC, Juraj Lutter
juraj: maintainer-approval+
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Juraj Lutter 2020-09-19 22:19:13 UTC
Created attachment 218093 [details]
net-mgmt/unifi6: Diff from net-mgmt/unifi5

Hi,

please find the patches attached. It brings a new port, unifi6 at version 6.0.22.

- First one is a diff from unifi5
- Second one is a full port
- shar archive is also provided

This is a followup of bug #249353.

Changelog since 6.0.20:
* Improvements:
  - Enable client statistics (option is no longer configurable).
  - System Settings Design Updates, new Scheduled Upgrade Modal.
  - Add sub page transitions.
  - Do not allow changing timezone, hostname and controller name on UniFi OS.
  - Improve Plug-and-Play adoption on UniFi OS.
  - Add "disabled" option for PMF in Beta Settings.

* Bugfixes:
  - Remove VLAN Only networks with 0 VLAN tag and assign Default LAN Network to affected WiFi Networks. (fix may not help in all reported cases yet)
  - Fix number of clients reported on dashboard.
  - Fix hostname validation rule.
  - Fix WAN IP uniqueness validation on save.
  - Fix issues submitting site-to-site VPN Configuration in Beta Settings.
  - Fix Creating VPN’s on UDM's (that could result in commit errors).
  - Move "Enable Smart Queues" tooltip to label.
  - Added error message for RADIUS secret length.
  - Show Content Filtering for UDM and UXG family devices only.
  - Get WLAN limit for each band separately in Beta Settings.
  - Style and component fixes in property panel.

* Known issues:
  - VLANs beyond UAP wireless downlinks may not have connectivity - under investigation


Testport from 13-CURRENT:
https://freebsd-current.builder.wilbury.net/data/13cgx64-default/2020-09-19_23h57m26s/logs/unifi6-6.0.22.log

Caution: 6.0.20 had a regression (https://community.ui.com/questions/Broadcast-storm-after-Unifi-controller-upgrade-to-6-0-20/0b924047-0632-4304-bada-4158a0a5349e) that should have been fixed in this release (provided that the user did not use 6.0.20 between 5.x and 6.0.22). If they did, then a manual intervention would be probably needed, as described in the URL.
Comment 1 Juraj Lutter 2020-09-19 22:19:49 UTC
Created attachment 218094 [details]
unifi6 full diff
Comment 2 Juraj Lutter 2020-09-19 22:20:56 UTC
Created attachment 218095 [details]
net-mgmt/unifi6: shar of port
Comment 3 DocWilco 2020-09-25 12:05:21 UTC
The Makefile still says "UniFi Controller v5"
Comment 4 Juraj Lutter 2020-09-25 12:18:15 UTC
For whatever reason I've missed that one. Will update the files in a few.
Comment 5 Ronald Klop 2020-09-25 15:03:35 UTC
I welcome this port very much. Please mind the following.

This depends on mongodb36 and mongodb36 is planned for removal on 2020-12-31.
See bug #249597
Comment 6 Juraj Lutter 2020-09-25 15:11:11 UTC
This also depends on the fact how Ubiquiti will support MongoDB 4.x.

I remember that there were some problem reported although I really should test this.
Comment 7 Juraj Lutter 2020-09-25 17:36:00 UTC
Created attachment 218289 [details]
net-mgmt/unifi6: shar of port
Comment 8 Juraj Lutter 2020-09-25 17:36:58 UTC
Created attachment 218290 [details]
net-mgmt/unifi6: Update to 6.0.23
Comment 9 Juraj Lutter 2020-09-25 17:38:18 UTC
Created attachment 218291 [details]
net-mgmt/unifi6: Diff from net-mgmt/unifi5
Comment 10 Juraj Lutter 2020-09-25 17:39:02 UTC
In the meantime, 6.0.23 is out. Changelog:

Changelog since 6.0.22:
* Improvements
  - Add MAC Address Filtering for WLAN.
  - Limit maximum shown upload/download utilization to 100%.
* Bugfixes
  - Fix Accordions in Beta Settings Networks from being unable to open.
  - WiFi AI - fix excluded channels dropdown/list.
  - System Settings -> Updates: use 24h format if it is set in system settings.
  - Ensure DHCP Relay section can be found in search.
  - Update AP Group form labels.
Known issues
  - VLANs beyond UAP wireless downlinks may not have connectivity - under investigation

Changelog for 6.0.22:
* Improvements:
  - Enable client statistics (option is no longer configurable).
  - System Settings Design Updates, new Scheduled Upgrade Modal.
  - Add sub page transitions.
  - Do not allow changing timezone, hostname and controller name on UniFi OS.
  - Improve Plug-and-Play adoption on UniFi OS.
  - Add "disabled" option for PMF in Beta Settings.

* Bugfixes:
  - Remove VLAN Only networks with 0 VLAN tag and assign Default LAN Network to affected WiFi Networks. (fix may not help in all reported cases yet)
  - Fix number of clients reported on dashboard.
  - Fix hostname validation rule.
  - Fix WAN IP uniqueness validation on save.
  - Fix issues submitting site-to-site VPN Configuration in Beta Settings.
  - Fix Creating VPN’s on UDM's (that could result in commit errors).
  - Move "Enable Smart Queues" tooltip to label.
  - Added error message for RADIUS secret length.
  - Show Content Filtering for UDM and UXG family devices only.
  - Get WLAN limit for each band separately in Beta Settings.
  - Style and component fixes in property panel.

* Known issues:
  - VLANs beyond UAP wireless downlinks may not have connectivity - under investigation

Changelog for 6.0.20 (the first 6.0.x release):

* What’s New in 6.0?
  - Introduce Beta Dashboard for UDM.
  - Implement Real-Time statistics for UDM.
  - Preview new Beta Settings.
  - Redesign, simplify and move Site, Controller, Maintenance, Remote Access and Backup configuration to System Settings.
  - Hide and auto-configure Data Retention for Statistics.
  - Redesign and move Wi-Fi AI configuration to System Settings page.
  - Redesign and move RADIUS and Switch Port profiles to Advanced Features page.
  - Redesign and move Services to Advanced Gateway Settings to Advanced Features page.
  - Move User Groups to Client Groups on Advanced Features page.
  - Redesign and move Wireless Networks configuration to Wi-Fi page.
  - Replace WLAN Groups with new AP Groups feature.
  - Simplify WiFi creation - WPA2 Security protocol with Password is set by default.
  - Allow selecting WPA2 Enterprise Security Protocol if at least one Radius profile is enabled.
  - Change VLAN ID numeric input to Network dropdown.
  - Integrate Guest Control with Hotspot configuration on Wi-Fi page.
  - Redesign and move LAN Networks configuration to Networks page.
  - Add Auto Scale Network feature.
  - Move VLAN Only Networks to Network Isolation in Advanced Features.
  - Update Content Filtering categories and move to Network configuration.
  - Add new Device Isolation (creates guest network if turned on) and Internet Access (blocks WAN access if turned off) toggles.
  - Redesign and move WAN Networks configuration to Internet page.
  - Redesign and move DPI configuration to Security page.
  - Redesign and move Threat Management configuration to Security page.
  - Introduce AP Groups feature.
  - AP Groups simplifies the way to configure Wi-Fi and arrange APs in logical groups.
  - That feature is replacing WLAN Groups and WLAN Overrides. It’s a breaking change and some corner cases may not covered by migration.
  - Some WLAN Group configurations have been migrated to individual Wi-Fi Network configurations.
  - Preview Auto Scale Network feature.
  - That feature automatically adjusts subnet size and DHCP range with avoiding network collision.
  - Add ability to report incorrect Wi-Fi Experience.
  - Add Survey for Beta Dashboard and Beta Settings.

* Improvements:
  - Add transition animations in Beta Settings.
  - Add buttons for guest client authentication and unauthentication.
  - Replace Speed test gauge with numbers.
  - Move PMF to WLAN configuration in Beta Settings.
  - Show AP promo placeholder in the new dashboard when there is no WiFi network created.
  - Show Original vendor logos when device logo is unavailable.
  - Remove Combine Name/SSID option from Settings.
  - Improve the user experience of AP Group validation in Beta Settings.

* Bugfixes:
  - Fix Settings intro video not playing.
  - Fix scrolling in Property panel in Beta Clients page.
  - Fix Peak Usage in the New Dashboard.
  - Fix width for columns in network table.
  - Fix saving DHCP Relay mode for network.
  - Fix stretched vendor logos on Beta Clients page.
  - Fix available actions for editing Admins.
  - Fix TxRate value on Clients page.
  - Fix redirect URL in Cloud version of New Settings.
  - Fix opening WLAN configuration page in New Settings.
  - Fix DHCP initial values that made Cancel and Apply buttons show without making any changes.
  - Fix Port Table value display.
  - Fix problems with Device adoption.
  - Fix visual style in client property panel Overview section.
  - Fix selected columns not being saved in clients table.
  - Fix multiple 404 errors.
  - Fix Network configuration for LTE failover when there is no connected LTE device.
  - Fix the "go to old dashboard" banner keeps reappearing after dismissal.
  - Fix packet count formatting on Beta Clients page.
  - Fix scrollbar style in Beta Settings
  - Fix untoggable checkboxes in port configuration.
  - Fix issues with WiFi Satisfaction graph on New Dashboard.
  - Fix "No Clients" image position.
  - Facebook authentication in Hotspot is not allowing HTTP redirects anymore.
  - Add missing options for Hotspot SSID's.
  - Provision access points with VLAN id's from all LAN configurations.
  - Don't allow enabling Cloud Email without Remote Access enabled.
  - Exclude U-LTE and USP-Plug from AP Group device list.
  - Update create WiFi validation.
  - Corrected MAC Filter table column widths.

* Known issues:
  - VLANs beyond UAP wireless downlinks may not have conectivity.
  - Creating VPN's on UDM's may result in commit errors.
Comment 11 Mikael Urankar freebsd_committer 2020-10-03 09:44:25 UTC
I find this hard to read, can you put a newline after each commands instead?
+	@${FIND} -s \
+		${STAGEDIR}${JAVASHAREDIR}/unifi \
+		-not \
+		-type \
+		d | \
+		${SORT} | \
+		${SED} -e 's#^${STAGEDIR}${PREFIX}/##' \
+		>> \
+		${TMPPLIST}
Comment 12 Juraj Lutter 2020-10-03 10:54:58 UTC
Created attachment 218488 [details]
net-mgmt/unifi6: Update to 6.0.23

A bit reformatted patch (the previous one was left intact after portfmt)
Comment 13 Mikael Urankar freebsd_committer 2020-10-03 13:52:51 UTC
Is it possible to depend on a modern mongodb version?
mongod36 will be deleted at the end of the year, this port will have the same fate.
Comment 14 Ronald Klop 2020-10-05 11:38:18 UTC
(In reply to Juraj Lutter from comment #6)
I made a small report in July about using mongodb42 with Unifi5.
https://lists.freebsd.org/pipermail/freebsd-ports/2020-July/119045.html
Comment 15 Juraj Lutter 2020-10-05 11:47:07 UTC
I will do the tests with 4.0 as with 4.4, I've run into similar problems (with featureCompatiblityVersion) as well.

Still, Ubuquiti does seem to only support 3.6, AFAIK.
Comment 16 Ronald Klop 2020-10-05 11:52:02 UTC
(In reply to Juraj Lutter from comment #15)
In bug #249597 a fix to let mongodb36 use python3 is attached. I'm test building it now.
Comment 17 Juraj Lutter 2020-10-05 13:25:09 UTC
Test build works for me (mongodb 36 with python 3.7).
Comment 18 Ronald Klop 2020-10-05 14:17:12 UTC
(In reply to Juraj Lutter from comment #17)
If it runs correctly please reply in bug #249597 also.
Comment 19 Juraj Lutter 2020-10-05 16:15:43 UTC
Unifi6 with mongodb36 build with python3 works OK.
Comment 20 commit-hook freebsd_committer 2020-10-06 18:32:48 UTC
A commit references this bug:

Author: mikael
Date: Tue Oct  6 18:32:43 UTC 2020
New revision: 551591
URL: https://svnweb.freebsd.org/changeset/ports/551591

Log:
  net-mgmt/unifi6: create port

  The UniFi Controller allows you to manage Wireless, Routing & Switching,
  VoIP and Video of Ubiquiti Networks.

  Changelog:
    https://ubntwiki.com/products/software/unifi-controller/6.0_consolidated_change_log

  PR:		249466
  Submitted by:	Juraj Lutter

Changes:
  head/net-mgmt/Makefile
  head/net-mgmt/unifi6/
  head/net-mgmt/unifi6/Makefile
  head/net-mgmt/unifi6/distinfo
Comment 21 Mikael Urankar freebsd_committer 2020-10-06 18:40:14 UTC
Thanks!