Bug 249491 - mail/thunderbird: build failure with lots of link errors related to epoll_shim_*
Summary: mail/thunderbird: build failure with lots of link errors related to epoll_shim_*
Status: Closed DUPLICATE of bug 248232
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: freebsd-gecko (Nobody)
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2020-09-20 21:24 UTC by Gary
Modified: 2020-09-21 00:40 UTC (History)
0 users

See Also:
jbeich: maintainer-feedback+


Attachments
poudriere build log (417.00 KB, application/gzip)
2020-09-20 21:24 UTC, Gary
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Gary 2020-09-20 21:24:49 UTC
Created attachment 218121 [details]
poudriere build log

Hi,

For some reason my thunderbird builds are failing with errors such as:

Unified_cpp_widget_gtk0.cpp:(.text._ZN20WaylandDMABufSurface16GlobalRefReleaseEv
+0x24): undefined reference to `epoll_shim_read'
Unified_cpp_widget_gtk0.cpp:(.text._ZN20WaylandDMABufSurface12GlobalRefAddEv+0x2
c): undefined reference to `epoll_shim_write'

Not entirely sure why.  Any help please?

Poudriere build log attached

Thank you
Comment 1 Jan Beich freebsd_committer 2020-09-21 00:40:22 UTC
Enable OPTIMIZED_CFLAGS (default) port option.

*** This bug has been marked as a duplicate of bug 248232 ***