Bug 249518 - misc/pinfo won't build on arm64 (missing sbrrk)
Summary: misc/pinfo won't build on arm64 (missing sbrrk)
Status: Closed Works As Intended
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: arm64 Any
: --- Affects Some People
Assignee: freebsd-ports-bugs (Nobody)
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2020-09-21 23:55 UTC by tech-lists
Modified: 2020-10-03 13:59 UTC (History)
1 user (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description tech-lists 2020-09-21 23:55:11 UTC
Hi,

Context is 1300115 / ports r365846

This won't build on arm64 because of missing sbrk
Comment 1 Mikael Urankar freebsd_committer 2020-10-03 09:35:50 UTC
(In reply to tech-lists from comment #0)
sbrk is not implemented on FreeBSD / aarch64 and the port is already marked as broken on aarch64: BROKEN_aarch64= Fails to link: missing sbrk
Do you have a patch to fix the build?
Comment 2 Mikael Urankar freebsd_committer 2020-10-03 13:59:34 UTC
Feel free to reopen if you have a patch.