Bug 249534 - graphics/opencolorio: update to git snapshot
Summary: graphics/opencolorio: update to git snapshot
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: Steve Wills
URL:
Keywords:
: 249695 (view as bug list)
Depends on:
Blocks: 249337
  Show dependency treegraph
 
Reported: 2020-09-22 20:27 UTC by Steve Wills
Modified: 2020-09-27 13:41 UTC (History)
2 users (show)

See Also:
bugzilla: maintainer-feedback? (FreeBSD)
swills: merge-quarterly-
swills: exp-run-


Attachments
patch to update opencolorio (36.58 KB, patch)
2020-09-22 20:27 UTC, Steve Wills
swills: maintainer-approval? (FreeBSD)
Details | Diff
remove py2.7 usage from opencolorio (7.83 KB, patch)
2020-09-26 02:44 UTC, Shane
FreeBSD: maintainer-approval+
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Steve Wills freebsd_committer 2020-09-22 20:27:02 UTC
Created attachment 218190 [details]
patch to update opencolorio

This builds and works with python 3, the current version requires Python 2.7.
Comment 1 Shane 2020-09-23 09:41:45 UTC
While I want to make some adjustments, this patch has two ports that don't exist

textproc/py-sphinx_press_theme
devel/pystring
Comment 2 Steve Wills freebsd_committer 2020-09-23 18:14:52 UTC
(In reply to Shane from comment #1)
Oh, they exist on my system, I just forgot to commit them. I'll do it now.
Comment 3 Steve Wills freebsd_committer 2020-09-23 18:31:16 UTC
(In reply to Shane from comment #1)
Those are added now, please take another look. Thanks!
Comment 4 Steve Wills freebsd_committer 2020-09-24 17:05:59 UTC
*** Bug 249695 has been marked as a duplicate of this bug. ***
Comment 5 Shane 2020-09-25 08:03:39 UTC
At this stage only one end user port builds against this new version. With the 2.0 release planned to be before the end of year, I would rather wait for the official release, pushing the projects using it to update in time for the release.

If this is only about using py2 for anyone that wants to build the docs, the docs option can be removed from the current v1 port so there is no mention of py2.

The affected ports that need updating for ocio v2 -

graphics/blender - this is mine
graphics/krita
graphics/photoflow

graphics/openfx-arena - this uses ocio but was only used by one qt4 port (natron) that has been deleted. The github project for this has gone so this could be due for deletion.
Comment 6 Shane 2020-09-26 02:44:33 UTC
Created attachment 218305 [details]
remove py2.7 usage from opencolorio

As a quick fix, this removes the DOCS option and reference to py2.7
Comment 7 commit-hook freebsd_committer 2020-09-27 13:40:58 UTC
A commit references this bug:

Author: swills
Date: Sun Sep 27 13:40:17 UTC 2020
New revision: 550274
URL: https://svnweb.freebsd.org/changeset/ports/550274

Log:
  graphics/opencolorio: remove python 2.7 usage

  PR:		249534
  Submitted by:	Shane Ambler <FreeBSD@Shaneware.biz> (maintainer)

Changes:
  head/graphics/opencolorio/Makefile
  head/graphics/opencolorio/pkg-plist
Comment 8 Steve Wills freebsd_committer 2020-09-27 13:41:58 UTC
Looks good to me, committed. Thanks!