Bug 249586 - chinese/pyzy: depends on python 2.x
Summary: chinese/pyzy: depends on python 2.x
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: Rene Ladan
URL:
Keywords:
Depends on:
Blocks: 249337
  Show dependency treegraph
 
Reported: 2020-09-24 16:19 UTC by Steve Wills
Modified: 2021-01-01 13:28 UTC (History)
2 users (show)

See Also:
henry.hu.sh: maintainer-feedback+


Attachments
patch create_db.py for python3 (4.01 KB, patch)
2020-10-11 20:28 UTC, Henry Hu
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Steve Wills freebsd_committer 2020-09-24 16:19:43 UTC
This port will be removed on 2020-12-31 if not fixed
Comment 1 Henry Hu 2020-10-11 20:28:25 UTC
Created attachment 218671 [details]
patch create_db.py for python3

Used 2to3, then manually edited. Now it works.
Comment 2 Henry Hu 2020-10-11 20:29:10 UTC
tested the patch on poudriere. This should make the port work with py3.
Comment 3 Rene Ladan freebsd_committer 2021-01-01 13:28:13 UTC
Patch committed, thanks for submitting it.
Comment 4 commit-hook freebsd_committer 2021-01-01 13:28:33 UTC
A commit references this bug:

Author: rene
Date: Fri Jan  1 13:27:53 UTC 2021
New revision: 559827
URL: https://svnweb.freebsd.org/changeset/ports/559827

Log:
  chinese/pyzy: build with Python 3 instead of expired Python 2.7

  PR:		249586
  Submitted by:	swills (patch from maintainer)

Changes:
  head/chinese/pyzy/Makefile
  head/chinese/pyzy/files/patch-data_db_android_create__db.py