Bug 249626 - devel/py-backports.os: depends on python 2.x
Summary: devel/py-backports.os: depends on python 2.x
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: Kai Knoblich
URL:
Keywords:
Depends on:
Blocks: 249337
  Show dependency treegraph
 
Reported: 2020-09-24 16:23 UTC by Steve Wills
Modified: 2020-10-30 07:33 UTC (History)
0 users

See Also:
kai: maintainer-feedback+


Attachments
patch to deprecate port (544.99 KB, patch)
2020-09-24 18:40 UTC, Steve Wills
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Steve Wills freebsd_committer 2020-09-24 16:23:01 UTC
This port will be removed on 2020-12-31 if not fixed
Comment 1 Steve Wills freebsd_committer 2020-09-24 18:40:53 UTC
Created attachment 218255 [details]
patch to deprecate port
Comment 2 commit-hook freebsd_committer 2020-10-30 07:31:02 UTC
A commit references this bug:

Author: kai
Date: Fri Oct 30 07:30:09 UTC 2020
New revision: 553670
URL: https://svnweb.freebsd.org/changeset/ports/553670

Log:
  devel/py-backports.os: Deprecate port

  * Deprecate and set an expiration date as the port is only useful in
    conjunction with Python 2.7 which will be removed to the end of 2020.

  PR:		249626
  Submitted by:	swills

Changes:
  head/devel/py-backports.os/Makefile
Comment 3 Kai Knoblich freebsd_committer 2020-10-30 07:33:22 UTC
(In reply to Steve Wills from comment #0)

Committed, thank you for the patch and the heads-up!