Bug 249635 - devel/py-enum34: depends on python 2.x
Summary: devel/py-enum34: depends on python 2.x
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: Muhammad Moinur Rahman
URL:
Keywords:
Depends on:
Blocks: 249337
  Show dependency treegraph
 
Reported: 2020-09-24 16:23 UTC by Steve Wills
Modified: 2020-09-25 19:26 UTC (History)
0 users

See Also:
bugzilla: maintainer-feedback? (bofh)


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Steve Wills freebsd_committer 2020-09-24 16:23:37 UTC
This port will be removed on 2020-12-31 if not fixed
Comment 1 Muhammad Moinur Rahman freebsd_committer 2020-09-25 09:06:56 UTC
Hi Swills,
This is just the enum library backported for 2.7-3.3. So it is pretty safe to delete once python 2.7 is no longer in the tree.

Should I set an EXPIRATION_DATE or just close this ticket ?
Comment 2 Steve Wills freebsd_committer 2020-09-25 11:49:47 UTC
(In reply to Muhammad Moinur Rahman from comment #1)
EXPIRATION_DATE would be nice, thanks!
Comment 3 commit-hook freebsd_committer 2020-09-25 19:25:15 UTC
A commit references this bug:

Author: bofh
Date: Fri Sep 25 19:25:12 UTC 2020
New revision: 550071
URL: https://svnweb.freebsd.org/changeset/ports/550071

Log:
  devel/py-enum34: Update version 1.1.6=>1.1.10

  - Mark DEPRECATED and set EXPIRATION_DATE in line with python27 [1]

  PR:		249635 [1]
  Reported by:	swills [1]

Changes:
  head/devel/py-enum34/Makefile
  head/devel/py-enum34/distinfo