Bug 249675 - devel/viewvc: depends on python 2.x
Summary: devel/viewvc: depends on python 2.x
Status: Closed Overcome By Events
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: Olli Hauer
URL:
Keywords:
Depends on:
Blocks: 249337
  Show dependency treegraph
 
Reported: 2020-09-24 16:26 UTC by Steve Wills
Modified: 2020-12-31 17:51 UTC (History)
4 users (show)

See Also:
bugzilla: maintainer-feedback? (ohauer)


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Steve Wills freebsd_committer 2020-09-24 16:26:20 UTC
This port will be removed on 2020-12-31 if not fixed
Comment 1 Li-Wen Hsu freebsd_committer 2020-09-28 15:55:28 UTC
This is used by https://svnweb.freebsd.org/
Comment 2 Olli Hauer freebsd_committer 2020-10-05 11:50:27 UTC
There is some work upstream on https://github.com/viewvc/viewvc
However, until now there is no new release supporting python3.
I can only suggest to look into a different solution like websvn-php or usvn since I do not belive there will be a release before python2 is removed from ports
Comment 3 Dan Langille freebsd_committer 2020-11-30 14:40:29 UTC
I contacted upstream regarding a Python 3 release of their code:

  https://github.com/viewvc/viewvc/issues/236

In short, they said use what's on master.

From that, devel/viewvc-devel was created using Python 3 - I'm running that at home.

The work was based on:

* https://bugs.freebsd.org/bugzilla/show_bug.cgi?id=247161
* https://bugs.freebsd.org/bugzilla/show_bug.cgi?id=247804
Comment 4 Rene Ladan freebsd_committer 2020-12-31 17:51:14 UTC
Expired port removed, use devel/viewvc-devel instead.