Bug 249678 - editors/atom: depends on python 2.x
Summary: editors/atom: depends on python 2.x
Status: New
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: Hiroki Tagato
URL:
Keywords:
Depends on:
Blocks: 249337
  Show dependency treegraph
 
Reported: 2020-09-24 16:26 UTC by Steve Wills
Modified: 2020-10-17 12:43 UTC (History)
1 user (show)

See Also:
bugzilla: maintainer-feedback? (tagattie)


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Steve Wills freebsd_committer 2020-09-24 16:26:35 UTC
This port will be removed on 2020-12-31 if not fixed
Comment 1 break19 2020-10-17 12:43:16 UTC
It's also a bit out of date.

1.52 is released and wants electron 6 rather than 5.

it also can be compiled with python 3.x on linux at least. my opensuse box has it built with python3.8 for example.

however, the code seems to be full of linuxisms and will likely require many patches to build here. It's a shame, as it's my favorite IDE.