Bug 249686 - games/0ad: depends on python 2.x
Summary: games/0ad: depends on python 2.x
Status: Closed Overcome By Events
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: Guido Falsi
URL:
Keywords:
Depends on:
Blocks: 249337
  Show dependency treegraph
 
Reported: 2020-09-24 16:27 UTC by Steve Wills
Modified: 2020-12-31 19:23 UTC (History)
1 user (show)

See Also:
madpilot: maintainer-feedback+


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Steve Wills freebsd_committer 2020-09-24 16:27:27 UTC
This port will be removed on 2020-12-31 if not fixed
Comment 1 Guido Falsi freebsd_committer 2020-09-24 19:37:30 UTC
Thanks for the reminder.

I also contacted upstream in relation to this issue, and while they are working on it they don't think they will be able to propose a solution by the end of the year.

At worst the port will die and I will add it back to the tree once upstream provides a new version which uses modern python.
Comment 2 Rene Ladan freebsd_committer 2020-12-31 18:15:21 UTC
Expired port removed. Feel free to re-add a py3 version ;)
Comment 3 Guido Falsi freebsd_committer 2020-12-31 19:23:10 UTC
(In reply to Rene Ladan from comment #2)
I'm working with upstream to get the next release back into the ports tree, depending on python 3, but it will take some more work.