Bug 249710 - lang/spidermonkey60: depends on python 2.x
Summary: lang/spidermonkey60: depends on python 2.x
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: Tobias C. Berner
URL:
Keywords:
Depends on:
Blocks: 249337
  Show dependency treegraph
 
Reported: 2020-09-24 16:30 UTC by Steve Wills
Modified: 2020-09-24 19:36 UTC (History)
0 users

See Also:
tcberner: maintainer-feedback+


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Steve Wills freebsd_committer 2020-09-24 16:30:14 UTC
This port will be removed on 2020-12-31 if not fixed
Comment 1 Tobias C. Berner freebsd_committer 2020-09-24 19:12:29 UTC
Moin moin 

lang/spidermonkey60's only reason of existence was an older polkit version. 
The new polkit 0.118 depends on a python3 using spidermonkey.

So I don't see any reason to invest time in making it work in a python3 world.


mfg Tobias
Comment 2 commit-hook freebsd_committer 2020-09-24 19:35:15 UTC
A commit references this bug:

Author: tcberner
Date: Thu Sep 24 19:35:08 UTC 2020
New revision: 549944
URL: https://svnweb.freebsd.org/changeset/ports/549944

Log:
  lang/spidermonkey60: mark deprecated (uses python2 to build)

  This port was added for a past polkit update.
  Newer spidermonkey version can be built with python3 and should be prefered.

  PR:		249710
  Reported by:	swills

Changes:
  head/lang/spidermonkey60/Makefile