Bug 249724 - multimedia/kodi: depends on python 2.x
Summary: multimedia/kodi: depends on python 2.x
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: Bernhard Froehlich
URL:
Keywords:
Depends on: 248692
Blocks: 249337
  Show dependency treegraph
 
Reported: 2020-09-24 16:31 UTC by Steve Wills
Modified: 2020-12-30 12:22 UTC (History)
2 users (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Steve Wills freebsd_committer 2020-09-24 16:31:54 UTC
This port will be removed on 2020-12-31 if not fixed
Comment 1 Bernhard Froehlich freebsd_committer 2020-12-07 07:28:15 UTC
In PR 248692 an update to kodi 18.9 is being discussed which might land before python 2.7 EoL BUT we need at least kodi 19.0 which was released just 3 weeks ago. So I expect that we will hit the EoL date.

Is the removal of python 2.7 dependent ports still a hard deadline or are grace periods being considered (like the mailman2 discussion)?
Comment 2 Bernhard Froehlich freebsd_committer 2020-12-07 08:26:05 UTC
To correct myself there is currently no python 3.x compatible kodi release because kodi 19.0 is at beta2 at the moment.
Comment 3 Bernhard Froehlich freebsd_committer 2020-12-29 20:52:50 UTC
An update for multimedia/kodi to 19.0b2 is prepared and will be committed tomorrow.
Comment 4 commit-hook freebsd_committer 2020-12-30 12:16:32 UTC
A commit references this bug:

Author: decke
Date: Wed Dec 30 12:15:45 UTC 2020
New revision: 559651
URL: https://svnweb.freebsd.org/changeset/ports/559651

Log:
  multimedia/kodi: Update to 19.0b2
  We usually try to avoid updating to beta releases but this time we were
  forced by the upcoming python2.7 removal and had to hurry up to get it
  into the tree before 31st. Bugs are expected and testing was limited.
  Kodi 19.0 will be the first release that supports python3 so we had no
  other choice. Sorry!

  The maintainer situation for kodi and kodi-devel really needs some
  improvement so I'm glad that yzrh did the heavy lifting and stepped up
  as the next kodi maintainer. Thanks a lot to him!

  PR:		249724
  Submitted by:	yzrh@tuta.io (per email)

Changes:
  head/multimedia/kodi/Makefile
  head/multimedia/kodi/distinfo
  head/multimedia/kodi/files/patch-xbmc_dbwrappers_mysqldataset.cpp
  head/multimedia/kodi/files/patch-xbmc_dbwrappers_mysqldataset.h
  head/multimedia/kodi/files/patch-xbmc_platform_linux_input_LibInputHandler.cpp
  head/multimedia/kodi/files/patch-xbmc_windowing_rpi_WinSystemRpi.cpp
  head/multimedia/kodi/pkg-plist
Comment 5 Bernhard Froehlich freebsd_committer 2020-12-30 12:22:57 UTC
Problem resolved.