Bug 249756 - science/gnudatalanguage: depends on python 2.x
Summary: science/gnudatalanguage: depends on python 2.x
Status: Open
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: Thierry Thomas
URL:
Keywords:
Depends on:
Blocks: 249337
  Show dependency treegraph
 
Reported: 2020-09-24 16:34 UTC by Steve Wills
Modified: 2020-09-24 17:19 UTC (History)
0 users

See Also:
thierry: maintainer-feedback+


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Steve Wills freebsd_committer 2020-09-24 16:34:22 UTC
This port will be removed on 2020-12-31 if not fixed
Comment 1 Thierry Thomas freebsd_committer 2020-09-24 17:18:55 UTC
You're right, and upstream knows the situation (same thing on many Linux distros).
They are working on gdl-v1.0.0, which will depend on Python 3.x.

v1.0.0-rc.3 has been out since June 19, but there remains some caveats:
https://github.com/gnudatalanguage/gdl/issues