Bug 249788 - www/moinmoin: depends on python 2.x
Summary: www/moinmoin: depends on python 2.x
Status: Closed Overcome By Events
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: freebsd-python (Nobody)
URL: https://github.com/moinwiki/moin-1.9/...
Keywords:
Depends on:
Blocks: 249337
  Show dependency treegraph
 
Reported: 2020-09-24 16:36 UTC by Steve Wills
Modified: 2021-01-01 00:17 UTC (History)
2 users (show)

See Also:
bugzilla: maintainer-feedback? (python)


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Steve Wills freebsd_committer 2020-09-24 16:36:28 UTC
This port will be removed on 2020-12-31 if not fixed
Comment 1 Loïc Bartoletti freebsd_committer 2020-11-11 08:00:10 UTC
> MoinMoin 1.9.x only works on Python 2.7 and there is no plan to change the code to work on Python 3.
> 
> MoinMoin 2 (not released yet) will work on Python 3.x soon.
> 
> See also: https://moinmo.in/Python3

From: https://github.com/moinwiki/moin-1.9/issues/5
Comment 2 Rene Ladan freebsd_committer 2021-01-01 00:17:57 UTC
Expired port, will be removed soon. Moinmoin 2 would be a new port.