Bug 249791 - www/py-beautifulsoup32: depends on python 2.x
Summary: www/py-beautifulsoup32: depends on python 2.x
Status: Closed Works As Intended
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: Danilo G. Baio
URL:
Keywords:
Depends on:
Blocks: 249337
  Show dependency treegraph
 
Reported: 2020-09-24 16:36 UTC by Steve Wills
Modified: 2020-11-01 01:43 UTC (History)
2 users (show)

See Also:
bugzilla: maintainer-feedback? (mwm)


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Steve Wills freebsd_committer 2020-09-24 16:36:40 UTC
This port will be removed on 2020-12-31 if not fixed
Comment 1 Steve Wills freebsd_committer 2020-10-18 20:26:25 UTC
There's a www/py-beautifulsoup that's newer, I think this was for compatibility with other things, but they have all been removed, so I think this can go too.
Comment 2 Danilo G. Baio freebsd_committer 2020-11-01 01:43:38 UTC
Beautiful Soup 3 was the official release line of Beautiful Soup from May 2006 to March 2012. It does not support Python 3 and it will be discontinued on or after December 31, 2020β€”one year after the Python 2 sunsetting date. If you have any active projects using Beautiful Soup 3, you should migrate to Beautiful Soup 4 as part of your Python 3 conversion.

https://www.crummy.com/software/BeautifulSoup/