Bug 249875 - databases/postgresql13-server: Unable to build package with LLVM enabled due to missing files
Summary: databases/postgresql13-server: Unable to build package with LLVM enabled due ...
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: amd64 Any
: --- Affects Only Me
Assignee: pgsql
URL:
Keywords:
: 249887 (view as bug list)
Depends on:
Blocks:
 
Reported: 2020-09-25 10:29 UTC by Alexander Kuznetsov
Modified: 2020-09-27 20:19 UTC (History)
3 users (show)

See Also:
bugzilla: maintainer-feedback? (pgsql)


Attachments
Patch to fix build problems WRT llvm (10.69 KB, patch)
2020-09-25 18:07 UTC, Palle Girgensohn
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Alexander Kuznetsov 2020-09-25 10:29:17 UTC
I'm trying to build PostgreSQL 13 server with LLVM JIT enabled from ports, but packaging phase fails due to missing next files:

[00:07:44] =======================<phase: package        >============================
[00:07:44] ===>  Building package for postgresql13-server-13.0
[00:07:44] pkg-static: Unable to access file /wrkdirs/usr/ports/databases/postgresql13-server/work/stage/usr/local/lib/postgresql/bitcode/postgres/access/heap/tuptoaster.bc:No such file or directory
[00:07:44] pkg-static: Unable to access file /wrkdirs/usr/ports/databases/postgresql13-server/work/stage/usr/local/lib/postgresql/bitcode/postgres/lib/stringinfo.bc:No such file or directory
[00:07:44] pkg-static: Unable to access file /wrkdirs/usr/ports/databases/postgresql13-server/work/stage/usr/local/lib/postgresql/bitcode/postgres/utils/adt/txid.bc:No such file or directory
[00:07:44] pkg-static: Unable to access file /wrkdirs/usr/ports/databases/postgresql13-server/work/stage/usr/local/lib/postgresql/bitcode/postgres/utils/hash/hashfn.bc:No such file or directory
[00:07:44] pkg-static: Unable to access file /wrkdirs/usr/ports/databases/postgresql13-server/work/stage/usr/local/lib/postgresql/bitcode/postgres/utils/mb/encnames.bc:No such file or directory
[00:07:44] pkg-static: Unable to access file /wrkdirs/usr/ports/databases/postgresql13-server/work/stage/usr/local/lib/postgresql/bitcode/postgres/utils/mb/wchar.bc:No such file or directory

FreeBSD 12.1 amd64.
Comment 1 Palle Girgensohn freebsd_committer 2020-09-25 17:06:14 UTC
*** Bug 249887 has been marked as a duplicate of this bug. ***
Comment 2 Palle Girgensohn freebsd_committer 2020-09-25 18:07:27 UTC
Created attachment 218292 [details]
Patch to fix build problems WRT llvm

Hi!

Does this patch help?

It works for me, but the port is acting a bit strange WRT option settings.

Palle
Comment 3 Alexander Kuznetsov 2020-09-25 20:19:05 UTC
(In reply to Palle Girgensohn from comment #2)

Hi!

Yes, it does. The port passess all build stages successfully since I've applied the attached patch. Thank you!
Comment 4 commit-hook freebsd_committer 2020-09-27 20:18:09 UTC
A commit references this bug:

Author: girgen
Date: Sun Sep 27 20:17:58 UTC 2020
New revision: 550339
URL: https://svnweb.freebsd.org/changeset/ports/550339

Log:
  Fix building with LLVM

  Fix a plist issue [1].

  Make sure the LLVM options are correctly handled. Setting the OPTIONS_DEFAULT
  conditionally based on wheather the default compiler is cland doesn't work
  properly, it is always set even if you deselect it. Just setting it per default
  seems to work better.

  Attempt a fix for building on FreeBSD-13.0 where clang is newer than the
  default LLVM. First attempt is to use an lower version clang to match what LLVM
  has as default. [2]

  PR:	244403 [2], 249933 [2], 249875 [1]

Changes:
  head/databases/postgresql13-server/Makefile
  head/databases/postgresql13-server/pkg-plist-server
Comment 5 Palle Girgensohn freebsd_committer 2020-09-27 20:19:19 UTC
Fix committed. Thanks for the report!