Bug 249888 - databases/postgresql13-contrib: Still depends on version 12
Summary: databases/postgresql13-contrib: Still depends on version 12
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Some People
Assignee: pgsql
URL:
Keywords:
: 249911 (view as bug list)
Depends on:
Blocks:
 
Reported: 2020-09-25 15:03 UTC by Christian Ullrich
Modified: 2020-09-27 09:29 UTC (History)
2 users (show)

See Also:
bugzilla: maintainer-feedback? (pgsql)


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Christian Ullrich 2020-09-25 15:03:56 UTC
The -contrib port depends on the -client, and the version of this dependency is hardcoded in the Makefile.

When the Makefile was copied for version 13, this was not changed, so the postgresql13-contrib package has a dependency on postgresql12-client.

Proposed fix: Replace the fixed version with the same expression that is in the -server Makefile.
Comment 1 commit-hook freebsd_committer 2020-09-25 15:54:39 UTC
A commit references this bug:

Author: girgen
Date: Fri Sep 25 15:53:44 UTC 2020
New revision: 550051
URL: https://svnweb.freebsd.org/changeset/ports/550051

Log:
  Fix depenedency for postgresql13-contrib

  And avoid hardcoding the version for all other versions as well, per suggestion
  in the PR.

  PR:		249888
  Submitted by:	Christian Ullrich

Changes:
  head/databases/postgresql10-contrib/Makefile
  head/databases/postgresql11-contrib/Makefile
  head/databases/postgresql12-contrib/Makefile
  head/databases/postgresql13-contrib/Makefile
  head/databases/postgresql95-contrib/Makefile
Comment 2 Palle Girgensohn freebsd_committer 2020-09-25 16:07:56 UTC
Committed. Thanks!
Comment 3 Palle Girgensohn freebsd_committer 2020-09-27 09:29:27 UTC
*** Bug 249911 has been marked as a duplicate of this bug. ***