Bug 249892 - net/py-s3cmd: add option for devel/py-python-magic
Summary: net/py-s3cmd: add option for devel/py-python-magic
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Package Infrastructure (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Many People
Assignee: Dan Langille
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2020-09-25 16:36 UTC by Dan Langille
Modified: 2020-09-28 13:56 UTC (History)
1 user (show)

See Also:


Attachments
allow devel/py-python-magic as an option (1.00 KB, patch)
2020-09-25 16:36 UTC, Dan Langille
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Dan Langille freebsd_committer 2020-09-25 16:36:56 UTC
Created attachment 218287 [details]
allow devel/py-python-magic as an option

This patch adds an option for using devel/py-python-magic as a dependency instead of py-magic.

The existing behavior of the port is maintained by using devel/py-magic as the default.

Why add this option?

Because devel/py-python-magic and devel/py-magic are conflicting ports, this change allows users to install py-s3cmd alongside packages which use devel/py-python-magic.

Confirmed working here.
Comment 1 Adam Weinberger freebsd_committer 2020-09-26 01:05:19 UTC
This is a build/install fix and covered by the portmgr blanket. I'm not sure whether you actually meant to assign it to us, but you are free to commit it at your own discretion.
Comment 2 Dan Langille freebsd_committer 2020-09-28 13:32:52 UTC
(In reply to Adam Weinberger from comment #1)

I did not intend to send it to portmgr. :)
Comment 3 commit-hook freebsd_committer 2020-09-28 13:47:45 UTC
A commit references this bug:

Author: dvl
Date: Mon Sep 28 13:47:10 UTC 2020
New revision: 550427
URL: https://svnweb.freebsd.org/changeset/ports/550427

Log:
  add option for devel/py-python-magic

  PR:		249892
  Submitted by:	Dan Langille <dvl@FreeBSD.org>
  Approved by:	portmgr (blanket)

Changes:
  head/net/py-s3cmd/Makefile