Bug 249911 - databases/postgresql13-contrib: dependence on databases/postgresql12-client
Summary: databases/postgresql13-contrib: dependence on databases/postgresql12-client
Status: Closed DUPLICATE of bug 249888
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: pgsql
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2020-09-26 10:43 UTC by O. Hartmann
Modified: 2020-09-27 09:29 UTC (History)
1 user (show)

See Also:
bugzilla: maintainer-feedback? (pgsql)


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description O. Hartmann 2020-09-26 10:43:53 UTC
For reasons unknown to me, installing databases/postgresql13-contrib tries to install databases/postgresql12-client (Version 12, not 13!) due to line

USES=       bison pgsql:12

in the Makefile. This ends up in a conflict when databases/postgresql13-client is already installed (which usually does). I can only assume this is a typo when derived postgresql 13 port from its progenitor 12.
Comment 1 Palle Girgensohn freebsd_committer 2020-09-27 09:29:27 UTC
Thanks for reporting! This was fixed in 249888.

Best regards,
Palle

*** This bug has been marked as a duplicate of bug 249888 ***