Bug 249927 - x11/mate: Applications fails to start: CRITICAL: polkit_authority_check_authorization: assertion 'POLKIT_IS_AUTHORITY (authority)' failed
Summary: x11/mate: Applications fails to start: CRITICAL: polkit_authority_check_autho...
Status: Closed Overcome By Events
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: amd64 Any
: --- Affects Only Me
Assignee: freebsd-ports-bugs (Nobody)
URL:
Keywords: needs-qa
Depends on:
Blocks:
 
Reported: 2020-09-27 00:43 UTC by andy
Modified: 2020-10-01 20:46 UTC (History)
4 users (show)

See Also:
tcberner: maintainer-feedback+
koobs: maintainer-feedback? (gnome)


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description andy 2020-09-27 00:43:00 UTC
FreeBSD Free_BSD_13 13.0-CURRENT FreeBSD 13.0-CURRENT #0 r366158: Fri Sep
25 12:23:15 EDT 2020
root@Free_BSD_13:/usr/obj/usr/src/amd64.amd64/sys/MYKERNEL.bak  amd64
1300117

After a recent upgrade of base system, kernel and all ports my desktop is
broken.

From log:

Sep 25 14:25:17 Free_BSD_13 mate-session[78320]: WARNING: Could not
connect to ConsoleKit: Could not get owner of name
'org.freedesktop.ConsoleKit': no such name
Sep 25 14:25:17 Free_BSD_13 syslogd: last message repeated 1 times
Sep 25 14:25:17 Free_BSD_13 mate-session[78320]: WARNING: Unable to find
provider '' of required component 'dock'
Sep 25 14:25:18 Free_BSD_13 gnome-keyring-daemon[85947]: The PKCS#11
component was already initialized
Sep 25 14:25:18 Free_BSD_13 gnome-keyring-daemon[85947]: The Secret
Service was already initialized
Sep 25 14:25:18 Free_BSD_13 gnome-keyring-daemon[85947]: The SSH agent was
already initialized
Sep 25 14:25:18 Free_BSD_13 console-kit-daemon[4901]: CRITICAL:
polkit_authority_check_authorization: assertion 'POLKIT_IS_AUTHORITY
(authority)' failed

Now nothing is working, unable to start any applications.
Comment 1 Tobias C. Berner freebsd_committer 2020-09-27 07:51:48 UTC
Moin moin 

Is the console-kit-daemon running, and do you have active ck-sessions?


mfg Tobias
Comment 2 andy 2020-09-27 12:05:47 UTC
(In reply to Tobias C. Berner from comment #1)

# ps -aux | grep console-kit-daemon
root       78021    0.0  0.0   51404    6748  -  I    Fri15       0:00.48 /usr/local/sbin/console-kit-daemon --no-daemon
root        9533    0.0  0.0   11336    2184  3  S+   08:03       0:00.00 grep console-kit-daemon

"do you have active ck-sessions?"
How do I check for this?

# ps -aux | grep ck-sessions       
root        9982    0.0  0.0   11264    2224  3  S+   08:04       0:00.00 grep ck-sessions
Comment 3 andy 2020-09-27 12:10:20 UTC
Disregard comment 2, I have to check on different machine I will reply again later.
Comment 4 andy 2020-09-27 18:32:05 UTC
# ps -aux | grep console-kit-daemon
root       78021    0.0  0.0   51404    6748  -  I    Fri15       0:00.48 /usr/local/sbin/console-kit-daemon --no-daemon
root        9533    0.0  0.0   11336    2184  3  S+   08:03       0:00.00 grep console-kit-daemon

"do you have active ck-sessions?"
How do I check for this?

# ps -aux | grep ck-sessions       
root        9982    0.0  0.0   11264    2224  3  S+   08:04       0:00.00 grep ck-sessions

Problem is still occurring.
Comment 5 Tobias C. Berner freebsd_committer 2020-09-27 18:34:05 UTC
(In reply to andy from comment #4)
Unfortunately, I don't see any problem here with my plasma desktop.


Are all your packages up to date?


mfg Tobias
Comment 6 andy 2020-09-27 18:47:08 UTC
Yes all packages are up to date.
Comment 7 Steve Wills freebsd_committer 2020-09-28 17:48:46 UTC
(In reply to andy from comment #6)
I've tried reproducing this locally by building and installing x11/mate and am not seeing an issue. Can you provide your full package list and any non-default options you may have set as well as any make.conf or src.conf customization?
Comment 8 andy 2020-09-29 21:00:04 UTC
Hi Steve:

Thanks for taking the time to look at this, it's a long list so I posted it here:

https://sebsauvage.net/paste/?a9b6f5b86970e280#8+niNXsvXLe8ibp5oKXcdPj4oK5FI8WIm0FtU+lntdI=

# cat /etc/make.conf 
MALLOC_PRODUCTION=yes

# cat /etc/src.conf 
WITHOUT_REPRODUCIBLE_BUILD=yes

It's a pretty standard desktop system, not doing anything crazy except maybe for running compiz.
Comment 9 Steve Wills freebsd_committer 2020-09-30 21:35:53 UTC
(In reply to andy from comment #8)
Seems like you're missing the 'mate' package itself, but you have most of the other stuff. That's about the only thing I see that looks off.
Comment 10 andy 2020-10-01 20:44:05 UTC
I have 2 different physical hard disks with the same installations.  I added the Mate meta-port to both as Steve suggested.  After restarting, one disk works correctly the other does not.  So at this point I'm not really sure whats going on.  I used a disk copy device and made a duplicate of the good disk and now have 2 good working copies.  Will close this out.