Bug 249966 - USB config SX lock
Summary: USB config SX lock
Status: New
Alias: None
Product: Base System
Classification: Unclassified
Component: usb (show other bugs)
Version: CURRENT
Hardware: Any Any
: --- Affects Only Me
Assignee: freebsd-usb (Nobody)
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2020-09-28 22:28 UTC by Bjoern A. Zeeb
Modified: 2020-09-30 21:03 UTC (History)
1 user (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Bjoern A. Zeeb freebsd_committer 2020-09-28 22:28:28 UTC
Given I am regularly having these "USB config SX lock" hangs I would love to track them, hence opening this PR.

Here's the first one to track (not the first one I keep seeing):

In this case a micro SD card on da3 did not show up with partitions anymore; the da1 on the same card reader still worked.  Unplugging the card reader checking on USB in order to reset it gave me this:

# usbconfig
load: 0.27  cmd: usbconfig 61812 [USB config SX lock] 1.61r 0.00u 0.00s 0% 2120k
mi_switch+0xc1 sleepq_catch_signals+0x3d1 sleepq_wait_sig+0x9 _sx_xlock_hard+0x451 usbd_enum_lock_sig+0xa1 usb_ref_device+0x221 usb_open+0x106 devfs_open+0x145 VOP_OPEN_APV+0x1c vn_open_vnode+0x1eb vn_open_cred+0x3b7 kern_openat+0x248 amd64_syscall+0x119 fast_syscall_common+0xf8

"can ^c"

xhci on a Kaby Lake system.
Neither the other USB3 not the USB-C port detect anythign new plugged in currently.  Not tried to disable enumeration yet.
Had unplugged an external mass storage on USB3/da4 yesterday and not used the still plugged-in reader since.  Was camcontrol ejected da4.