Bug 249969 - ports-mgmt/portlint: Please do not warn about defining USE_LDCONFIG for linux libs
Summary: ports-mgmt/portlint: Please do not warn about defining USE_LDCONFIG for linux...
Status: Closed Works As Intended
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: Joe Marcus Clarke
URL:
Keywords: needs-patch
Depends on:
Blocks:
 
Reported: 2020-09-28 23:33 UTC by Yuri Victorovich
Modified: 2020-11-29 17:58 UTC (History)
2 users (show)

See Also:
bugzilla: maintainer-feedback? (marcus)


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Yuri Victorovich freebsd_committer 2020-09-28 23:33:23 UTC
If libraries are installed into /compat/linux - do not print these:
> WARN: /usr/ports/net-im/zoom/pkg-plist: [1099]: installing shared libraries, please define USE_LDCONFIG as appropriate


Testcase: net-im/zoom
Comment 1 Joe Marcus Clarke freebsd_committer 2020-11-29 16:51:54 UTC
Hey, Yuri.  I've looked at some other ports, and I think the proper way to do what you're doing is set USE_LINUX_PREFIX.  This will cause the Linux ldconfig to run when you set USE_LDCONFIG.  Meaning, I think you absolutely do need ldconfig when installing shared libs, you just need to instruct the ports system which to use.

In your case, you could set USE_LINUX_PREFIX, and then use a fully qualified /%%LOCALBASE%%/bin/zoom, etc. to install the files outside of LINUXBASE.
Comment 2 Yuri Victorovich freebsd_committer 2020-11-29 17:49:29 UTC
(In reply to Joe Marcus Clarke from comment #1)

> In your case, you could set USE_LINUX_PREFIX, and then use a fully qualified /%%LOCALBASE%%/bin/zoom, etc. to install the files outside of LINUXBASE.

But this is also not desired because these shared libraries should be only used form one app.
The desired behavior here is to exclude them from ldconfig.
Comment 3 Joe Marcus Clarke freebsd_committer 2020-11-29 17:58:39 UTC
That's fair, but this is also not a general case.  In some cases (e.g., devel/linux-c7-icu), ldconfig should be run.  Simply checking if LINUXBASE is the target would not be sufficient.  Not all portlint messages are necessary valid.  That's why this is a WARN.  

I wonder if some kind of "# noqa" check is required like exists for linters like flake8 for Python...