Bug 250037 - re(4): TP-Link TG-3468 V4 network card not detected
Summary: re(4): TP-Link TG-3468 V4 network card not detected
Status: Closed FIXED
Alias: None
Product: Base System
Classification: Unclassified
Component: kern (show other bugs)
Version: Unspecified
Hardware: amd64 Any
: --- Affects Some People
Assignee: Mark Johnston
URL:
Keywords: easy, feature, needs-patch, needs-qa
Depends on:
Blocks:
 
Reported: 2020-10-02 00:20 UTC by Hiroshi HASEGAWA
Modified: 2020-10-12 16:45 UTC (History)
3 users (show)

See Also:
koobs: maintainer-feedback? (kevlo)
markj: mfc-stable12+
koobs: mfc-stable11?


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Hiroshi HASEGAWA 2020-10-02 00:20:24 UTC
I bought TP-Link TG-3468 V4 network card.
The card include RTL8168H but it not work.

I report a result of `pciconf -lv` .
I confirmed to modify array re_devs[], sys/dev/re/if_re.c, deviceid = 0x8161 

	{ RT_VENDORID, 0x8161, 0,
	    "TP-Link TG-3468 v4 (RTL8168H) Gigabit Ethernet" },

The card looks like working.
Please add this device id.

---
none2@pci0:1:0:0: class=0x020000 card=0x816810ec chip=0x816110ec rev=0x15 hdr=0x00
    vendor     = 'Realtek Semiconductor Co., Ltd.'
    class      = network
    subclass   = ethernet

Thanks.
Comment 1 Kubilay Kocak freebsd_committer freebsd_triage 2020-10-02 03:22:36 UTC
^Triage: kevlo@ added TP-Link TG-3468 v2 support in base r306102, request feedback
Comment 2 Kevin Lo freebsd_committer 2020-10-02 14:14:12 UTC
(In reply to Kubilay Kocak from comment #1)

I added v2, but Hiroshi's card is v4.
Comment 3 commit-hook freebsd_committer 2020-10-05 19:59:35 UTC
A commit references this bug:

Author: markj
Date: Mon Oct  5 19:58:56 UTC 2020
New revision: 366464
URL: https://svnweb.freebsd.org/changeset/base/366464

Log:
  re(4): Add a 8168-compatible device ID

  This is described in RealTek's driver as a "RTL8168 Series add-on card."

  PR:		250037
  Submitted by:	Hiroshi HASEGAWA <hhase1973@gmail.com>
  MFC after:	1 week

Changes:
  head/sys/dev/re/if_re.c
  head/sys/dev/rl/if_rlreg.h
Comment 4 commit-hook freebsd_committer 2020-10-12 16:44:10 UTC
A commit references this bug:

Author: markj
Date: Mon Oct 12 16:44:06 UTC 2020
New revision: 366649
URL: https://svnweb.freebsd.org/changeset/base/366649

Log:
  MFC r366464:
  re(4): Add a 8168-compatible device ID

  PR:	250037

Changes:
_U  stable/12/
  stable/12/sys/dev/re/if_re.c
  stable/12/sys/dev/rl/if_rlreg.h
Comment 5 Mark Johnston freebsd_committer 2020-10-12 16:45:29 UTC
Thanks for the report.