Bug 250057 - x11/gnome3 does not appear to work properly in 2020Q4 or latest
Summary: x11/gnome3 does not appear to work properly in 2020Q4 or latest
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Many People
Assignee: freebsd-gnome (Nobody)
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2020-10-02 20:25 UTC by mvharding
Modified: 2020-10-13 08:03 UTC (History)
4 users (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description mvharding 2020-10-02 20:25:45 UTC
I've been using Poudriere for a while to update ports on my 12.1 machine. Recently X stopped working so I dropped back to the 2020Q3 branch, which works. I built the 2020Q4 branch and X fails to work properly. This also occurs on a virtualbox instance, you might want to do a Gnome 3 setup on a Virtualbox instance of 12.1 before releasing 2020Q4.
Comment 1 mvharding 2020-10-03 18:07:16 UTC
Sorry, I should say that Gnome3 does not appear to work properly. I get the 'Oh no, something has gone wrong! white screen. This happens after an update, or after a full clean install, so it should be easy to duplicate.
Comment 2 Mark Linimon freebsd_committer freebsd_triage 2020-10-04 03:22:47 UTC
(In reply to mvharding from comment #0)

> you might want to do a Gnome 3 setup on a Virtualbox instance of 12.1 before releasing 2020Q4.

2020Q4 has already been tagged.

fwiw, 'Package Infrastructure' is only for the package building machines @FreeBSD.org.
Comment 3 Henri Hennebert 2020-10-06 15:24:16 UTC
After a `portupgrade -ua` I encounter the same problem.

Here is my /var/log/gdm/:0-greeter.log:

dbus-daemon[1701]: [session uid=92 pid=1701] Activating service name='org.a11y.Bus' requested by ':1.0' (uid=92 pid=1704 comm="/usr/local/libexec/gnome-session-check-accelerated")
dbus-daemon[1701]: [session uid=92 pid=1701] Successfully activated service 'org.a11y.Bus'
gnome-session-binary 1702 - - WARNING: Unable to find required component 'org.gnome.SettingsDaemon.Clipboard'
gnome-session-binary 1702 - - WARNING: Unable to find required component 'org.gnome.SettingsDaemon.Mouse'

gnome-session-failed: environment corrupt; missing value for GNOME_SESSION_AUTOSTART_DIR

dbus-daemon[1707]: Activating service name='org.a11y.atspi.Registry' requested by ':1.1' (uid=92 pid=1709 comm="/usr/local/libexec/gnome-session-failed --allow-lo")
dbus-daemon[1707]: Successfully activated service 'org.a11y.atspi.Registry'
SpiRegistry daemon is running with well-known name - org.a11y.atspi.Registry
Comment 4 Anders Bolt-Evensen 2020-10-07 09:01:29 UTC
(In reply to Henri Hennebert from comment #3)
I have the same problem as Henri reported in their post. I also tried to install Gnome on a spare laptop and encountered the same error there too.
Comment 5 Konstantin 2020-10-08 09:49:43 UTC
(In reply to Henri Hennebert from comment #3)
I got the same errors. Now I start gnome-session in shell:
startx /usr/local/bin/gnome-session
Comment 6 Henri Hennebert 2020-10-08 10:44:20 UTC
(In reply to Konstantin from comment #5)
Very good trick. Thank you! You save me!

Just one drawback for me: gnome-terminal don't work...
Comment 7 Konstantin 2020-10-08 10:50:21 UTC
(In reply to Henri Hennebert from comment #6)
Yeah, I had to switch to Urxvt:(
Comment 8 Henri Hennebert 2020-10-08 11:33:33 UTC
(In reply to Konstantin from comment #7)
This can be solved by running in a xterm this script before trying to ro gnome-terminal:

#!/bin/sh
export LANG=en_US.UTF-8
export LANGUAGE=en_US
export LC_COLLATE=C
export LC_MESSAGES=en_US.UTF-8
/usr/local/libexec/gnome-terminal-server &

Henri
Comment 9 Baptiste Daroussin freebsd_committer 2020-10-09 21:29:47 UTC
should be fixed in both, the packages should slowly appear in your nearest mirrors
Comment 10 Anders Bolt-Evensen 2020-10-09 21:30:42 UTC
I can now confirm that the latest ports patch works for me and I am now able to log in to Gnome again.
Comment 11 mvharding 2020-10-10 18:38:05 UTC
Looks to be working via gdm now (I rebuilt via poudriere). I am having some minor issues (gnu terminal font looks double spaced, so the terminal is super wide, and the system is suspending due to inactivity, but there is no way to disable this (which may not be considered a bug by the developers, see https://gitlab.gnome.org/GNOME/gnome-control-center/-/issues/22, but certainly interferes with me running poudriere builds, which stop, or virtualbox, which will crash the system if suspended).

Thanks for all the work on this!
Comment 12 Ravi Raj 2020-10-11 18:16:25 UTC
Hi 

Can you please give the command for what you mean by switch to Urxvt?(In reply to Konstantin from comment #7)
Comment 13 Konstantin 2020-10-11 18:36:34 UTC
(In reply to Ravi Raj from comment #12)
You should have another terminal emulator to be installed. At lest, xterm. I have also rxvt-unicode(urxvt). Without proper configuration(.Xresources) they look quite old-fashioned. Install via pkg or ports.
https://www.freshports.org/x11/rxvt-unicode/
PS After this bug is fixed I'm sure Gnome Terminal should be available to run. I'll check tomorrow at work.
Comment 14 Anders Bolt-Evensen 2020-10-11 19:18:38 UTC
Can confirm that the Gnome terminal launches as normal now that the GNOME bug is fixed.
Comment 15 Anders Bolt-Evensen 2020-10-12 13:38:42 UTC
(In reply to mvharding from comment #11)
About the system suspending due to inactivity, I decided to do a little investigation. Running 'gsettings list-recursively | grep -i "suspend\|sleep"'; I got the following output:

gsettings list-recursively | grep -i "suspend\|sleep"
org.gnome.settings-daemon.plugins.media-keys suspend ['']
org.gnome.settings-daemon.plugins.media-keys hibernate-static ['XF86Suspend', 'XF86Hibernate']
org.gnome.settings-daemon.plugins.media-keys suspend-static ['XF86Sleep']
org.gnome.settings-daemon.plugins.power sleep-inactive-battery-type 'suspend'
org.gnome.settings-daemon.plugins.power sleep-inactive-ac-type 'suspend'
org.gnome.settings-daemon.plugins.power sleep-inactive-battery-timeout 1200
org.gnome.settings-daemon.plugins.power sleep-inactive-ac-timeout 1200
org.gnome.settings-daemon.plugins.power power-button-action 'suspend'

(process:45401): GLib-GIO-WARNING **: 15:29:12.495: Failed to parse translated string 'Regular' for key 'game-type' in schema 'org.gnome.tali': 0:expected value

(process:45401): GLib-GIO-WARNING **: 15:29:12.495: Using untranslated default instead.
org.freedesktop.Tracker.Miner.Files initial-sleep 15
ca.desrt.dconf-editor.Settings saved-pathbar-path '/org/gnome/settings-daemon/plugins/power/sleep-inactive-ac-type'

Notice that the default sleep-inactive-ac-timeout is 1200 seconds or 20 minutes.

As you said, there is no way to change anything via the GUI, but on a user-based setting, as a work-around, you can try changing the sleep-inactive-ac-timeout, like this:

gsettings set org.gnome.settings-daemon.plugins.power sleep-inactive-ac-timeout $seconds.

I changed it to 86400 seconds (24 hours). It may not be the perfect solution to the issue you mentioned, but on my end, it seems to work as a work-around.
Comment 16 Ravi Raj 2020-10-13 08:03:37 UTC
(In reply to Konstantin from comment #13)
hi

i am able to run eterm, but your command on gnome-session hangs! What can i do now?

thanks
ravi