Bug 250154 - textproc/meld : Cannot run since 3.21.0, require pygobject3 version 3.30
Summary: textproc/meld : Cannot run since 3.21.0, require pygobject3 version 3.30
Status: Closed Overcome By Events
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: freebsd-gnome (Nobody)
URL:
Keywords:
Depends on: 249944
Blocks:
  Show dependency treegraph
 
Reported: 2020-10-06 08:34 UTC by Thibault Payet
Modified: 2020-10-14 16:45 UTC (History)
4 users (show)

See Also:
bugzilla: maintainer-feedback? (gnome)


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Thibault Payet 2020-10-06 08:34:49 UTC
From the release note

* Updated dependencies:
     * Python 3.6
     * GTK+ 3.20
     * GLib 2.48
     * GtkSourceView 4.0
     * pygobject 3.30
     * pycairo 1.15

And also when running it just stop at pygobject version check
Comment 1 Charlie Li 2020-10-07 22:07:48 UTC
As a side note, this port should not have been updated to this version to begin with. This software follows the even-odd split, where odd versions are developmental releases.
Comment 2 Mikael Urankar freebsd_committer 2020-10-14 06:05:43 UTC
(In reply to Charlie Li from comment #1)
This should be documented in the Makefile
Comment 3 Guido Falsi freebsd_committer 2020-10-14 16:45:46 UTC
I reverted the update in r552342, and also merged that to quarterly, so meld should now work again.

I did have to bump PORTEPOCH for this, obviously.