Bug 250243 - shells/switchBashZsh: update to 1.1
Summary: shells/switchBashZsh: update to 1.1
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: freebsd-ports-bugs (Nobody)
URL: https://github.com/bourne-again/switc...
Keywords: needs-qa
Depends on:
Blocks:
 
Reported: 2020-10-10 07:29 UTC by bourne.identity@hotmail.com
Modified: 2020-11-10 18:13 UTC (History)
1 user (show)

See Also:


Attachments
svn diff for switchBashZsh v1.0 -> v1.1 (1.90 KB, patch)
2020-10-10 07:29 UTC, bourne.identity@hotmail.com
bourne.identity: maintainer-approval+
Details | Diff
current distinfo for switchBashZsh (197 bytes, text/plain)
2020-11-10 10:37 UTC, bourne.identity@hotmail.com
bourne.identity: maintainer-approval+
Details
current Makefile for switchBashZsh (619 bytes, text/plain)
2020-11-10 10:37 UTC, bourne.identity@hotmail.com
bourne.identity: maintainer-approval+
Details
current pkg-descr for switchBashZsh (812 bytes, text/plain)
2020-11-10 10:38 UTC, bourne.identity@hotmail.com
bourne.identity: maintainer-approval+
Details
current distinfo for switchBashZsh (197 bytes, text/plain)
2020-11-10 10:58 UTC, bourne.identity@hotmail.com
bourne.identity: maintainer-approval+
Details
current Makefile for switchBashZsh (619 bytes, text/plain)
2020-11-10 10:59 UTC, bourne.identity@hotmail.com
bourne.identity: maintainer-approval?
Details
current pkg-descr for switchBashZsh (812 bytes, text/plain)
2020-11-10 10:59 UTC, bourne.identity@hotmail.com
bourne.identity: maintainer-approval+
Details
REVISED diff (1.55 KB, patch)
2020-11-10 15:16 UTC, bourne.identity@hotmail.com
bourne.identity: maintainer-approval+
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description bourne.identity@hotmail.com 2020-10-10 07:29:14 UTC
Created attachment 218639 [details]
svn diff for switchBashZsh v1.0 -> v1.1

shells/switchBashZsh update to version 1.1

svn diff for switchBashZsh v1.0 -> v1.1 is attached.


Thank you,
Manish Jain
Comment 1 bourne.identity@hotmail.com 2020-10-22 03:51:47 UTC
The update primarily changes the license from GPL to BSD.
Comment 2 Fernando Apesteguía freebsd_committer 2020-11-10 08:21:02 UTC
^Triage: Simplifying title

^Triage: If there is a changelog or release notes URL available for this version, please add it to the URL field.

^Triage: Please set the maintainer-approval attachment flag (to +) on patches for ports you maintain to signify approval.
--
Attachment -> Details -> maintainer-approval [+]

Q/A: patch did not apply cleanly. Would you mind checking it?

The patch tries to set LICENSE to this:

+LICENSE=       BSD2CLAUSE

But that is already in the repo and hence, it fails. See https://svnweb.freebsd.org/ports/head/shells/switchBashZsh/Makefile?revision=550135&view=markup

Thanks!
Comment 3 bourne.identity@hotmail.com 2020-11-10 09:41:02 UTC
Hi Fernando,

We have a problem here. The patch was generated by `svn diff`, and the patch at my end produces the change GPL -> BSD. As a further complication, I think the actual LICENSE file previously in use was actually GPL (almost certainly owing to my mistake).

Can you manually correct things at your end ? Or else, send over a new patch file to me generated by `svn diff` (or something else) at your end ?


Thank you for taking this up,
Manish Jain
Comment 4 bourne.identity@hotmail.com 2020-11-10 10:35:24 UTC
I am uploading the current Makefile, distinfo and pkg-descr files at my end to help resolve the conflict.
Comment 5 bourne.identity@hotmail.com 2020-11-10 10:37:00 UTC
Created attachment 219509 [details]
current distinfo for switchBashZsh
Comment 6 bourne.identity@hotmail.com 2020-11-10 10:37:33 UTC
Created attachment 219510 [details]
current Makefile for switchBashZsh
Comment 7 bourne.identity@hotmail.com 2020-11-10 10:38:03 UTC
Created attachment 219511 [details]
current pkg-descr for switchBashZsh
Comment 8 bourne.identity@hotmail.com 2020-11-10 10:58:29 UTC
Created attachment 219512 [details]
current distinfo for switchBashZsh
Comment 9 bourne.identity@hotmail.com 2020-11-10 10:59:10 UTC
Created attachment 219513 [details]
current Makefile for switchBashZsh
Comment 10 bourne.identity@hotmail.com 2020-11-10 10:59:47 UTC
Created attachment 219514 [details]
current pkg-descr for switchBashZsh
Comment 11 Fernando Apesteguía freebsd_committer 2020-11-10 11:26:39 UTC
(In reply to bourne.identity@hotmail.com from comment #3)
Maybe you should update your repo first?

Just do that and attach a new patch. We should be fine :-)
Comment 12 bourne.identity@hotmail.com 2020-11-10 15:15:12 UTC
Hi Fernando,

I am sorry for the trouble caused by my previous oversight.

I did `svn up` and then regenerated the diff, which I am uploading as REVISED diff.

If this solves the issue, please do let me know.


And thanks again for helping me out,
Manish Jain
Comment 13 bourne.identity@hotmail.com 2020-11-10 15:16:01 UTC
Created attachment 219521 [details]
REVISED diff
Comment 14 commit-hook freebsd_committer 2020-11-10 15:58:41 UTC
A commit references this bug:

Author: fernape
Date: Tue Nov 10 15:58:18 UTC 2020
New revision: 554840
URL: https://svnweb.freebsd.org/changeset/ports/554840

Log:
  shells/switchBashZsh: update to 1.1

  ChangeLog: https://github.com/bourne-again/switchBashZsh/releases/tag/1.1

  PR:	250243
  Submitted by:	bourne.identity@hotmail.com (maintainer)

Changes:
  head/shells/switchBashZsh/Makefile
  head/shells/switchBashZsh/distinfo
  head/shells/switchBashZsh/pkg-descr
Comment 15 Fernando Apesteguía freebsd_committer 2020-11-10 16:01:48 UTC
(In reply to bourne.identity@hotmail.com from comment #12)

Manish, no worries! and thanks for the update. Next time, though, you can just mark the other attachments as obsolete so the PR remains clean :-)

Committed,

Thanks!
Comment 16 bourne.identity@hotmail.com 2020-11-10 18:13:58 UTC
Thanks so much, Fernando !