Bug 250329 - x11-fonts/firacode: Update to 5.2
Summary: x11-fonts/firacode: Update to 5.2
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: Dave Cottlehuber
URL: https://github.com/tonsky/FiraCode/re...
Keywords:
: 250051 (view as bug list)
Depends on:
Blocks:
 
Reported: 2020-10-13 22:30 UTC by Lewis Cook
Modified: 2020-10-17 13:15 UTC (History)
2 users (show)

See Also:
bugzilla: maintainer-feedback? (dch)


Attachments
firacode-5.2.diff (1.78 KB, patch)
2020-10-13 22:30 UTC, Lewis Cook
vulcan: maintainer-approval? (dch)
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Lewis Cook freebsd_triage 2020-10-13 22:30:09 UTC
Created attachment 218725 [details]
firacode-5.2.diff

Changelog:

 * https://github.com/tonsky/FiraCode/releases/tag/5.2

QA:

 * portlint: OK (looks fine).
 * testport: OK (poudriere: 12.1-RELEASE-p8, amd64).

MFH: No (Not applicable).
Comment 1 Dave Cottlehuber freebsd_committer 2020-10-17 11:48:51 UTC
*** Bug 250051 has been marked as a duplicate of this bug. ***
Comment 2 commit-hook freebsd_committer 2020-10-17 11:52:27 UTC
A commit references this bug:

Author: dch
Date: Sat Oct 17 11:51:49 UTC 2020
New revision: 552556
URL: https://svnweb.freebsd.org/changeset/ports/552556

Log:
  x11-fonts/firacode: update to 5.2 and remove XORG

  People running wayland etc don't want xorg as a hard dependency.

  PR:		250329
  Submitted by:	Lewis Cook <vulcan@wired.sh>
  Submitted by:	Namkhai B. <namkhai.n3@protonmail.com>
  Sponsored by:	SkunkWerks, GmbH

Changes:
  head/x11-fonts/firacode/Makefile
  head/x11-fonts/firacode/distinfo
  head/x11-fonts/firacode/pkg-plist
Comment 3 Dave Cottlehuber freebsd_committer 2020-10-17 13:15:47 UTC
thanks Lewis!