Bug 250341 - security/pam_ldap: Use upstream version of 186 instead of a made up 1.8.6
Summary: security/pam_ldap: Use upstream version of 186 instead of a made up 1.8.6
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: Joe Marcus Clarke
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2020-10-14 13:45 UTC by Mateusz Piotrowski
Modified: 2020-10-19 15:03 UTC (History)
0 users

See Also:
bugzilla: maintainer-feedback? (marcus)


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Mateusz Piotrowski freebsd_committer 2020-10-14 13:45:07 UTC
This would simplify the port's makefile and make us compatible with the rest of package managers: https://repology.org/project/pam-ldap/versions
Comment 1 commit-hook freebsd_committer 2020-10-19 15:02:41 UTC
A commit references this bug:

Author: marcus
Date: Mon Oct 19 15:02:16 UTC 2020
New revision: 552742
URL: https://svnweb.freebsd.org/changeset/ports/552742

Log:
  More cleanup.

  * Use the upstream 86 version instead of the artificial 1.8.6 [1]
  * Use @sample to handle the config file [2]

  Thanks to 0mp for the good suggestions.

  PR:		250341 [1]
  		250343 [2]

Changes:
  head/security/pam_ldap/Makefile
  head/security/pam_ldap/distinfo
  head/security/pam_ldap/files/patch-Makefile.in
  head/security/pam_ldap/files/pkg-message.in
  head/security/pam_ldap/pkg-plist
Comment 2 Joe Marcus Clarke freebsd_committer 2020-10-19 15:03:06 UTC
Fixed.  Thanks for the suggestion!