Bug 250367 - devel/llvm10: 10.0.1_1 failure to build clang failure
Summary: devel/llvm10: 10.0.1_1 failure to build clang failure
Status: Closed Not A Bug
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: amd64 Any
: --- Affects Many People
Assignee: Brooks Davis
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2020-10-15 12:43 UTC by Neil Groeber
Modified: 2020-10-19 11:20 UTC (History)
1 user (show)

See Also:
linimon: maintainer-feedback? (brooks)


Attachments
build failure log (95.19 KB, application/x-xz)
2020-10-15 12:46 UTC, Neil Groeber
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Neil Groeber 2020-10-15 12:43:40 UTC

    
Comment 1 Neil Groeber 2020-10-15 12:46:04 UTC
Created attachment 218760 [details]
build failure log
Comment 2 Brooks Davis freebsd_committer 2020-10-18 22:04:20 UTC
This is the configuration I do all my build testing with. Combined with "c++: error: unable to execute command: Killed" I'm guessing that you've run out of swap space (check dmesg to see why the process was killed).

You might try running /tmp/TransAutoreleasePool-692b28.sh and seeing if it runs to completion. If so, you may be able to succeed with DISABLE_MAKE_JOBS set.
Comment 3 Neil Groeber 2020-10-19 11:20:13 UTC
(In reply to Brooks Davis from comment #2)
Oh my word, how embarrassing, you are correct it was indeed and out of swap error, I don't know how I missed that.

I guess you can close this ticket.

All the best,

Neil Groeber