Bug 250411 - news/sabnzbdplus: Update to 3.2.1
Summary: news/sabnzbdplus: Update to 3.2.1
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Some People
Assignee: freebsd-ports-bugs (Nobody)
URL: https://github.com/sabnzbd/sabnzbd/re...
Keywords:
Depends on:
Blocks:
 
Reported: 2020-10-17 02:43 UTC by James French
Modified: 2021-05-12 20:29 UTC (History)
8 users (show)

See Also:


Attachments
Patch to 3.1.0 (4.91 KB, patch)
2020-10-17 02:43 UTC, James French
james: maintainer-approval+
Details | Diff
Poudriere build log (31.47 KB, text/plain)
2020-10-17 02:48 UTC, James French
no flags Details
Patch to 3.1.0 - Update cheroot (5.00 KB, patch)
2020-10-23 17:28 UTC, James French
no flags Details | Diff
3.1.0: Fix feedparser hard dependency (1.95 KB, patch)
2020-10-27 22:56 UTC, James French
no flags Details | Diff
Update to 3.1.1 (5.15 KB, patch)
2020-11-12 05:53 UTC, James French
no flags Details | Diff
Poudriere build log (31.85 KB, text/plain)
2020-11-12 05:54 UTC, James French
no flags Details
Update to 3.2.0 (6.11 KB, patch)
2021-03-01 08:42 UTC, James French
no flags Details | Diff
Poudriere build log (32.07 KB, text/plain)
2021-03-01 08:42 UTC, James French
no flags Details
Update to 3.2.1 (6.42 KB, patch)
2021-04-15 14:23 UTC, James French
no flags Details | Diff
Poudriere build log (31.60 KB, text/plain)
2021-04-15 14:24 UTC, James French
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description James French 2020-10-17 02:43:36 UTC
Created attachment 218821 [details]
Patch to 3.1.0

Maintainer update, 3.1.0 release.

Important note on Feedparser:

The Feedparser option is currently broken (requires feedparser >= 6.0.0). I have submitted a patch against bug 250380 to bring feedparser up to date (6.0.1).

The port otherwise works fine.
Comment 1 James French 2020-10-17 02:48:15 UTC
Created attachment 218822 [details]
Poudriere build log
Comment 2 Fernando Apesteguía freebsd_committer 2020-10-19 14:27:56 UTC
^Triage: Bugfix release, merge to quarterly branch.

^Triage: Maintainer-feedback flag (+) not required unless requested (?) first.


Thanks!
Comment 3 James French 2020-10-23 17:28:27 UTC
Created attachment 219010 [details]
Patch to 3.1.0 - Update cheroot

Upstream were holding with a dependency of <= 8.4.3 on www/py-cheroot due to a bug in 8.4.4.

8.4.5 has hit the ports tree, and has a fix but may have an additional regression. Updating the patch to be without the dependency issue.

Previous versions of sabnzbd would be similarly affected, so we'll see if anyone has issues and go from there.
Comment 4 commit-hook freebsd_committer 2020-10-26 19:46:41 UTC
A commit references this bug:

Author: adamw
Date: Mon Oct 26 19:45:48 UTC 2020
New revision: 553378
URL: https://svnweb.freebsd.org/changeset/ports/553378

Log:
  news/sabnzbdplus: Update to 3.1.0

  PR:		250411
  Submitted by:	maintainer

Changes:
  head/news/sabnzbdplus/Makefile
  head/news/sabnzbdplus/distinfo
  head/news/sabnzbdplus/pkg-plist
Comment 5 Adam Weinberger freebsd_committer 2020-10-26 19:48:36 UTC
I've committed the patch here, but I'm holding off on the MFH until we know there's no fallout from the regressions you mentioned.

James, when you feel confident that it's safe to MFH, please let me know (or if you think this update doesn't need to be merged to quarterly).
Comment 6 James French 2020-10-27 03:39:06 UTC
(In reply to Adam Weinberger from comment #5)

Ok, I've had a deeper dive through the issues, and I think what's left is log spam only and should be safe for this port.

If anyone stumbles across this, the relevant upstream issues are:
SabNZB: https://github.com/sabnzbd/sabnzbd/issues/1572
Cheroot: https://github.com/cherrypy/cheroot/issues/317

Cheroot 8.4.4 had a crash caused by a threading race condition. 8.4.5 the crash is resolved, but the race condition is still there which may cause log spam. No fix available yet but upstream SabNZB have given the ok on 8.4.5.

In either case, the quarterly branch is on 8.4.3 which is safe from both issues. 

This version resolves a number of issues with SabNZB so merging quarterly is probably a good idea.

Cheers
Comment 7 commit-hook freebsd_committer 2020-10-27 13:41:49 UTC
A commit references this bug:

Author: adamw
Date: Tue Oct 27 13:41:25 UTC 2020
New revision: 553440
URL: https://svnweb.freebsd.org/changeset/ports/553440

Log:
  MFH: r553378
  Approved by:	portmgr (with hat)

  news/sabnzbdplus: Update to 3.1.0

  PR:		250411
  Submitted by:	maintainer

Changes:
_U  branches/2020Q4/
  branches/2020Q4/news/sabnzbdplus/Makefile
  branches/2020Q4/news/sabnzbdplus/distinfo
  branches/2020Q4/news/sabnzbdplus/pkg-plist
Comment 8 James French 2020-10-27 22:56:34 UTC
Created attachment 219156 [details]
3.1.0: Fix feedparser hard dependency

An oversight on my part, feedparser is still in the default options list, but the patch to 6.0.1 on bug 250380 is still pending maintainer approval with still another 3 days before timeout.

Builds are failing with the default option set.

Further to that, it looks like this version has made feedparser a hard requirement too so just disabling the option introduces a runtime problem.

Attached makes feed parser a hard dependency, but the port will be broken until the other bug is resolved. I am wondering if rolling back sabnzbd makes more sense at this time.
Comment 9 Adam Weinberger freebsd_committer 2020-10-27 23:22:45 UTC
Ugh. I don't know why my poudriere was happy with this before commit.

What is the state of bug 250380? Your last comment in there talks about marking the port broken. Is the patch ready for commit (maintainer approval aside)?
Comment 10 Adam Weinberger freebsd_committer 2020-10-27 23:35:51 UTC
Ok well, sbz was never added to that PR so really the timeout period should probably start from today. I'll back this out of head and quarterly.
Comment 11 commit-hook freebsd_committer 2020-10-27 23:38:26 UTC
A commit references this bug:

Author: adamw
Date: Tue Oct 27 23:37:38 UTC 2020
New revision: 553512
URL: https://svnweb.freebsd.org/changeset/ports/553512

Log:
  news/sabnzbdplus: Back out r553378

  Feedburner needs to be a hard dependency, and the version currently
  in ports is incompatible.

  PR:		250411, 250380

Changes:
  head/news/sabnzbdplus/Makefile
  head/news/sabnzbdplus/distinfo
  head/news/sabnzbdplus/pkg-plist
Comment 12 commit-hook freebsd_committer 2020-10-27 23:39:30 UTC
A commit references this bug:

Author: adamw
Date: Tue Oct 27 23:38:36 UTC 2020
New revision: 553513
URL: https://svnweb.freebsd.org/changeset/ports/553513

Log:
  MFH: r553512
  Approved by:	portmgr (with hat)

  news/sabnzbdplus: Back out r553378

  Feedburner needs to be a hard dependency, and the version currently
  in ports is incompatible.

  PR:		250411, 250380

Changes:
_U  branches/2020Q4/
  branches/2020Q4/news/sabnzbdplus/Makefile
  branches/2020Q4/news/sabnzbdplus/distinfo
  branches/2020Q4/news/sabnzbdplus/pkg-plist
Comment 13 James French 2020-10-27 23:57:33 UTC
(In reply to Adam Weinberger from comment #9)

> Ugh. I don't know why my poudriere was happy with this before commit.

Mine was too, but I might have had the 6.0.1 feedparser patch in my overlay ports tree which was a mistake.

I did set this bug as depending on bug 250380, but it broke considerably more spectacularly than I was expecting.

> Your last comment in there talks about marking the port broken. Is the patch ready for commit (maintainer approval aside)?

Ready to go aside from the clean-up you've identified which I'll fix now. The "broken" aspect is that the latest version of feedparser requires shipping a Python 2 standard library that has had 2to3 run on it. If we don't do that, the port is broken, if we do (which is a bit messy) it works fine. There's no getting around that unfortunately as upstream have yet to port the code properly to Python 3.
Comment 14 James French 2020-11-12 05:53:38 UTC
Created attachment 219582 [details]
Update to 3.1.1

3.1.1 has been released, updating this patch. Still pending Feedparser update to >= 6.0.0 before this can be committed, see bug 250380
Comment 15 James French 2020-11-12 05:54:24 UTC
Created attachment 219583 [details]
Poudriere build log
Comment 16 James French 2021-03-01 08:42:26 UTC
Created attachment 222897 [details]
Update to 3.2.0

Still blocked by bug 250380 on textproc/py-feedparser
Comment 17 James French 2021-03-01 08:42:59 UTC
Created attachment 222898 [details]
Poudriere build log
Comment 18 James French 2021-04-15 14:23:05 UTC
Created attachment 224134 [details]
Update to 3.2.1

Feedparser 6.0.2 has been committed to the ports tree, this upgrade is no longer blocked. Bumping the patch to 3.2.1.

Thanks for the patience all.
Comment 19 James French 2021-04-15 14:24:33 UTC
Created attachment 224135 [details]
Poudriere build log
Comment 20 Daniel Kempkens 2021-04-23 15:14:08 UTC
The SAB version that is currently in the tree (3.0.2,1) is now broken because of the Feedparser update. Is there anything I can do to help get SAB updated to 3.2.1?

Traceback (most recent call last):
  File "/usr/local/bin/SABnzbd.py", line 1721, in <module>
    main()
  File "/usr/local/bin/SABnzbd.py", line 1224, in main
    sabnzbd.initialize(pause, clean_up, evalSched=True, repair=repair)
  File "/usr/local/lib/python3.7/site-packages/sabnzbd/decorators.py", line 36, in call_func
    return f(*args, **kw)
  File "/usr/local/lib/python3.7/site-packages/sabnzbd/__init__.py", line 323, in initialize
    rss.init()
  File "/usr/local/lib/python3.7/site-packages/sabnzbd/rss.py", line 48, in init
    __RSS = RSSQueue()
  File "/usr/local/lib/python3.7/site-packages/sabnzbd/rss.py", line 209, in __init__
    patch_feedparser()
  File "/usr/local/lib/python3.7/site-packages/sabnzbd/rss.py", line 648, in patch_feedparser
    feedparser._FeedParserMixin.namespaces["http://www.newznab.com/DTD/2010/feeds/attributes/"] = "newznab"
AttributeError: module 'feedparser' has no attribute '_FeedParserMixin'
Comment 21 Adam Weinberger freebsd_committer 2021-04-23 15:19:32 UTC
The patch does need to be committed. I'm returning the PR to the pool so someone can make this happen.
Comment 22 Floren Munteanu 2021-05-03 04:35:33 UTC
I see the 3.2.1 patch attached, what exactly is the block? Can we please merge the patch? 3.0.2,1 is broken due to py38-feedparser-6 update.
Comment 23 James French 2021-05-03 06:24:14 UTC
No block from me (port maintainer), just needs someone to commit the patch to the tree. I've been dogfooding 3.2.1 for some time without issue.

It was blocked by feed-parser being out of date, but is now broken because that issue has been fixed.

3.3.0 is about to drop upstream shortly, I was toying with raising a new bug (and closing this one) to give it a bit more visibility. This bug is now 7 months old and is a ways down the list.
Comment 24 Dan Kotowski 2021-05-03 13:19:50 UTC
Do we want to bump the importance? This affects me and clearly others as well - is the "Affects Only Me" possibly keeping this lower on the TODO list?
Comment 25 Floren Munteanu 2021-05-03 15:40:00 UTC
@James French: who could commit the patch?
Comment 26 commit-hook freebsd_committer 2021-05-05 09:13:22 UTC
A commit in branch main references this bug:

URL: https://cgit.FreeBSD.org/ports/commit/?id=903174f474abeb09977c1ec9ddce5957ac386344

commit 903174f474abeb09977c1ec9ddce5957ac386344
Author:     James French <james@french.id.au>
AuthorDate: 2021-05-05 09:09:43 +0000
Commit:     Tim Bishop <tdb@FreeBSD.org>
CommitDate: 2021-05-05 09:09:43 +0000

    news/sabnzbdplus: Update to 3.2.1

    PR:             250411

 news/sabnzbdplus/Makefile         | 13 ++++++-------
 news/sabnzbdplus/distinfo         |  6 +++---
 news/sabnzbdplus/files/sabnzbd.in |  2 +-
 news/sabnzbdplus/pkg-plist        | 12 +++++++++++-
 4 files changed, 21 insertions(+), 12 deletions(-)
Comment 27 Tim Bishop freebsd_committer 2021-05-05 09:16:25 UTC
Committed. Sorry that it took so long for somebody to do it.
Comment 28 Floren Munteanu 2021-05-05 11:56:06 UTC
@James French: Now that the patch was merged, can we release the port?
Comment 29 James French 2021-05-05 12:11:17 UTC
(In reply to Floren Munteanu from comment #28)

The updated port is in the ports tree, that's the patch that was committed. If you're using git for your ports directory, git pull to get the updates and it's there right now ready to build.

If you're using portsnap or nightly packages, it should come through in the next day or two when the automated tools catch up. If that's the case and you need it sooner, you can apply the patch to your own ports tree. Portsnap will replace the patched files when they come through, but it will replace them with the same file so no harm done.

The quarterly branch (and packages) are still on 3.0.2, but feed parser 5.0.x is also still in the tree for the quarterly branch.
Comment 30 Floren Munteanu 2021-05-11 06:11:51 UTC
(In reply to James French from comment #29)

Any idea when the FreeBSD:12:amd64 build will be processed? The check was done on 2010-05-10 but the repo build and processed dates are behind. All repos have been updated, except the one I need. How lovely. :)

https://www.freshports.org/news/sabnzbdplus/
Comment 31 Adam Hertzberg 2021-05-12 20:29:43 UTC
(In reply to Floren Munteanu from comment #30)
FYI for posterities sake - It showed up on ports about 10 hours after the last comment looking for FreeBSD:12:amd64. This was about 6 days after the fix was checked in. I think the fix was likely checked in shortly after a build started and it seems to take about 3 days for the full build process to complete, so the fix got in the next build after the one it just missed.