Bug 250452 - FreeBSD-12.2-RC3/amd64: /etc/resolv.conf is always reset by resolvconf even when it is disabled
Summary: FreeBSD-12.2-RC3/amd64: /etc/resolv.conf is always reset by resolvconf even w...
Status: Closed Not A Bug
Alias: None
Product: Base System
Classification: Unclassified
Component: bin (show other bugs)
Version: Unspecified
Hardware: Any Any
: --- Affects Only Me
Assignee: freebsd-bugs (Nobody)
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2020-10-19 08:10 UTC by Rajeev Pillai
Modified: 2020-10-20 20:55 UTC (History)
2 users (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Rajeev Pillai 2020-10-19 08:10:57 UTC
On FreeBSD 12.2-RC3 amd64, /etc/resolv.conf is always created/reset by the
service "resolv" even when `resolv_enable="NO"' in /etc/rc.conf.

This is on a system with a static IPv4 address and dynamic IPv6 address.
The created /etc/resolv.conf contains only the gateway's IPv6 address, but,
since this home router/ISP combo. does not do IPv6, the sendmail service
takes a long time to start.
Comment 1 Bob Bishop 2020-10-19 09:24:09 UTC
Not a bug. The magic spell to disable resolvconf is `resolvconf="NO"' in /etc/resolvconf.conf, see resolvconf.conf(5)
Comment 2 Rajeev Pillai 2020-10-19 10:48:06 UTC
Spell worked. Close bug.
Comment 3 VVD 2020-10-20 16:34:14 UTC
(In reply to Rajeev Pillai from comment #2)
You can close it self.