Bug 250571 - www/youtube_dl: Use GENTOO as MASTER_SITES due to DMCA takedown
Summary: www/youtube_dl: Use GENTOO as MASTER_SITES due to DMCA takedown
Status: Closed Overcome By Events
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: freebsd-multimedia (Nobody)
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2020-10-24 07:20 UTC by daniel.engberg.lists
Modified: 2020-10-25 22:28 UTC (History)
3 users (show)

See Also:
bugzilla: maintainer-feedback? (multimedia)


Attachments
Patch for youtube_dl (534 bytes, patch)
2020-10-24 07:20 UTC, daniel.engberg.lists
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description daniel.engberg.lists 2020-10-24 07:20:39 UTC
Created attachment 219028 [details]
Patch for youtube_dl

Use GENTOO as MASTER_SITES as GitHub has locked down the youtube-dl repo.

Tested on FreeBSD 13.0-CURRENT r364979 (amd64)
Comment 1 daniel.engberg.lists 2020-10-24 07:23:18 UTC
This is a quick band-aid, GENTOO mirror list needs to be cleaned up and we should probably look into using https://github.com/l1ving/youtube-dl (short term) or replace it with youtube-dlc ( https://www.reddit.com/r/DataHoarder/comments/ir8ic6/youtubedlc_an_active_fork_of_youtubedl/g9v55og/?utm_source=reddit&utm_medium=web2x&context=3 )
Comment 2 daniel.engberg.lists 2020-10-24 07:33:06 UTC
We're taking a different route...
Comment 3 Hans Petter Selasky freebsd_committer 2020-10-24 09:55:02 UTC
Thank you for taking care of it. youtube_dl has legitimate uses too!
Comment 4 Tatsuki Makino 2020-10-24 21:46:14 UTC
legitimate uses :)

Now, if you click on the Latest anchor on the home page, it will take you to http://abf-downloads.openmandriva.org/ytdl/ . Mandriva Linux?
Comment 5 daniel.engberg.lists 2020-10-25 20:09:42 UTC
I think that's a quick band-aid solution until GitHub repo isn't locked down.
The main reason I closed this PR is because there were some concerns that pointing to another mirror would potentially add fuel to the fire. Short-term would be to switch repo alternatively just point users to the fork (see PR link) until the issue is resolved. https://bugs.freebsd.org/bugzilla/show_bug.cgi?id=250608
Comment 6 Tatsuki Makino 2020-10-25 22:13:07 UTC
Some ports depend on it and are enabled by default. e.g. multimedia/mpv
We will probably have to cut them out.
Comment 7 daniel.engberg.lists 2020-10-25 22:28:07 UTC
I did add a symlink option for compatibility and convenience in youtube-dlc as not all applications aren't aware of the fork but it's not enabled by default however.