Bug 250604 - sysutils/beats7: Update to 7.9.3
Summary: sysutils/beats7: Update to 7.9.3
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: freebsd-elastic (Nobody)
URL: https://www.elastic.co/guide/en/beats...
Keywords:
Depends on:
Blocks:
 
Reported: 2020-10-25 17:43 UTC by Juraj Lutter
Modified: 2020-10-30 01:59 UTC (History)
2 users (show)

See Also:
juraj: maintainer-feedback+


Attachments
sysutils/beats7: Update to 7.9.3 (70.93 KB, patch)
2020-10-25 17:43 UTC, Juraj Lutter
juraj: maintainer-approval+
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Juraj Lutter 2020-10-25 17:43:58 UTC
Created attachment 219072 [details]
sysutils/beats7: Update to 7.9.3

Hi,

please find the patch attched.

Changelog for 7.9.3:
* Bugfixes:
  - Affecting all Beats
    - The o365audit input and o365 module now recover from an authentication
      problem or other fatal errors, instead of terminating.
  - Auditbeat
    - system/socket: Fix a crash due to concurrent map read and write.
  - Filebeat
    - Add field limit check for AWS Cloudtrail flattened fields.
  - Metricbeat
    - Fix remote_write flaky test.
    - Fix panic in Kubernetes autodiscovery caused by storing stateless
      keystores.
    - Remove redundant dockersock volume mount to avoid problems on Kubernetes
      deployments that do not use docker as the container runtime.
Comment 1 commit-hook freebsd_committer 2020-10-27 05:01:10 UTC
A commit references this bug:

Author: tcberner
Date: Tue Oct 27 05:00:20 UTC 2020
New revision: 553415
URL: https://svnweb.freebsd.org/changeset/ports/553415

Log:
  sysutils/beats7: Update to 7.9.3

  Changelog for 7.9.3:
  * Bugfixes:
    - Affecting all Beats
      - The o365audit input and o365 module now recover from an authentication
        problem or other fatal errors, instead of terminating.
    - Auditbeat
      - system/socket: Fix a crash due to concurrent map read and write.
    - Filebeat
      - Add field limit check for AWS Cloudtrail flattened fields.
    - Metricbeat
      - Fix remote_write flaky test.
      - Fix panic in Kubernetes autodiscovery caused by storing stateless
        keystores.
      - Remove redundant dockersock volume mount to avoid problems on Kubernetes
        deployments that do not use docker as the container runtime.

  PR:		250604
  Submitted by:	Juraj Lutter <juraj@lutter.sk>

Changes:
  head/sysutils/beats7/Makefile
  head/sysutils/beats7/distinfo