Bug 250622 - New port: sysutils/ansible29 (To move sysutils/ansible from 2.9.7 to 2.10.2)
Summary: New port: sysutils/ansible29 (To move sysutils/ansible from 2.9.7 to 2.10.2)
Status: New
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Some People
Assignee: Nikolai Lifanov
URL:
Keywords:
Depends on:
Blocks: 250623 250624 250626
  Show dependency treegraph
 
Reported: 2020-10-26 06:02 UTC by Samy Mahmoudi
Modified: 2020-11-08 11:44 UTC (History)
1 user (show)

See Also:
bugzilla: maintainer-feedback? (lifanov)


Attachments
Patch file (16.26 KB, patch)
2020-10-26 06:02 UTC, Samy Mahmoudi
no flags Details | Diff
Patch file (16.27 KB, patch)
2020-10-26 07:58 UTC, Samy Mahmoudi
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Samy Mahmoudi 2020-10-26 06:02:20 UTC
Created attachment 219090 [details]
Patch file

Hi,

• Make the new port sysutils/ansible29 (based on sysutils/ansible)
• Do not make sysutils/ansible29 a slave port of sysutils/ansible (to separate the maintenance of upcoming versions >= 2.10 from current versions < 2.10)
• Update sysutils/ansible29 from 2.9.7 to 2.9.14
• Make the CONFLICTS declaration also effective with flavored ports
• Prevent unnecessary conflicts with Ansible modules (e.g. with ansible-lint)
• Reorder variables as prescribed by the FreeBSD Porter's Handbook [1]
• Temporarily disable the do-test target (it does not work, even on 2.9.7)


[1] https://www.freebsd.org/doc/en_US.ISO8859-1/books/porters-handbook/porting-order.html
Comment 1 Samy Mahmoudi 2020-10-26 06:27:33 UTC
Poudriere log:
http://logs.imp.ovh/py37-ansible29-2.9.14.log
Comment 2 Samy Mahmoudi 2020-10-26 07:58:01 UTC
Created attachment 219095 [details]
Patch file

I forgot to correct pkg-message.in. Now the log is:

• Make the new port sysutils/ansible29 (based on sysutils/ansible)
• Do not make sysutils/ansible29 a slave port of sysutils/ansible (to separate the maintenance of upcoming versions >= 2.10 from current versions < 2.10)
• Update sysutils/ansible29 from 2.9.7 to 2.9.14
• Make the CONFLICTS declaration also effective with flavored ports
• Prevent unnecessary conflicts with Ansible modules (e.g. with ansible-lint)
• Reorder variables as prescribed by the FreeBSD Porter's Handbook [1]
• Temporarily disable the do-test target (it does not work, even on 2.9.7)
• Make pkg-message.in correspond to 2.9 instead of 2.8
Comment 3 Samy Mahmoudi 2020-10-26 08:00:22 UTC
(In reply to Samy Mahmoudi from comment #2)

This time I forgot to copy-paste the last line... so the log is:

• Make the new port sysutils/ansible29 (based on sysutils/ansible)
• Do not make sysutils/ansible29 a slave port of sysutils/ansible (to separate the maintenance of upcoming versions >= 2.10 from current versions < 2.10)
• Update sysutils/ansible29 from 2.9.7 to 2.9.14
• Make the CONFLICTS declaration also effective with flavored ports
• Prevent unnecessary conflicts with Ansible modules (e.g. with ansible-lint)
• Reorder variables as prescribed by the FreeBSD Porter's Handbook [1]
• Temporarily disable the do-test target (it does not work, even on 2.9.7)
• Make pkg-message.in correspond to 2.9 instead of 2.8

[1] https://www.freebsd.org/doc/en_US.ISO8859-1/books/porters-handbook/porting-order.html