Bug 250741 - installing sndio 1.7.0 fails on 12.2
Summary: installing sndio 1.7.0 fails on 12.2
Status: Closed Not A Bug
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: Fernando Apesteguía
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2020-10-30 16:39 UTC by Philip Homburg
Modified: 2020-11-10 18:54 UTC (History)
1 user (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Philip Homburg 2020-10-30 16:39:52 UTC
pkg upgrade tries to install sndio 1.7.0 (on 12.2). This fails with:

[1/16] Installing sndio-1.7.0...
===> Creating groups.
Using existing group '_sndio'.
===> Creating users
Creating user '_sndio' with uid '702'.
pw: user '_sndio' disappeared during update
pkg: PRE-INSTALL script failed
Comment 1 Philip Homburg 2020-11-05 12:20:54 UTC
I found the issue. _sndio was in master.passwd but not in pwd.db.

After running pwd_mkdb it installed fine.

I have no clue where the inconsistency came from.
Comment 2 Fernando Apesteguía freebsd_committer 2020-11-10 18:54:03 UTC
Glad to hear you figure it out.

Closing since it is resolved and there are no more notifications about this.