Bug 250797 - databases/pecl-redis: needs update: 5.3.1 does not build with PHP 8.0; 5.3.2 is available from upstream
Summary: databases/pecl-redis: needs update: 5.3.1 does not build with PHP 8.0; 5.3.2 ...
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: Mikael Urankar
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2020-11-02 08:37 UTC by Kamigishi Rei
Modified: 2020-11-07 16:43 UTC (History)
2 users (show)

See Also:
daniel: maintainer-feedback+


Attachments
Updates port to 5.3.2 (908 bytes, patch)
2020-11-03 14:32 UTC, Daniel Ylitalo
daniel: maintainer-approval+
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Kamigishi Rei 2020-11-02 08:37:51 UTC
The issue (https://github.com/phpredis/phpredis/issues/1809) is fixed in 5.3.2.
Comment 1 Daniel Ylitalo 2020-11-03 14:32:24 UTC
Created attachment 219323 [details]
Updates port to 5.3.2

Attached patch passes poudriere testport + portlint -AC
Comment 2 commit-hook freebsd_committer 2020-11-07 16:42:01 UTC
A commit references this bug:

Author: mikael
Date: Sat Nov  7 16:41:44 UTC 2020
New revision: 554407
URL: https://svnweb.freebsd.org/changeset/ports/554407

Log:
  databases/pecl-redis: Update to 5.3.2o

  Changelog:
    https://pecl.php.net/package/redis/5.3.2

  PR:		250797
  Submitted by:	Daniel Ylitalo (maintainer)
  Reported by:	Kamigishi Rei

Changes:
  head/databases/pecl-redis/Makefile
  head/databases/pecl-redis/distinfo
Comment 3 Mikael Urankar freebsd_committer 2020-11-07 16:43:00 UTC
Thanks!