Bug 250845 - www/apache24: mod_proxy_uwsgi doesn't use default port of uwsgi:// scheme.
Summary: www/apache24: mod_proxy_uwsgi doesn't use default port of uwsgi:// scheme.
Status: Open
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Some People
Assignee: freebsd-apache (Nobody)
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2020-11-04 01:57 UTC by nork
Modified: 2020-11-15 14:44 UTC (History)
1 user (show)

See Also:
bugzilla: maintainer-feedback? (apache)


Attachments
a patch to modules/proxy/proxy_util.c (341 bytes, patch)
2020-11-04 01:57 UTC, nork
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description nork 2020-11-04 01:57:13 UTC
Created attachment 219340 [details]
a patch to modules/proxy/proxy_util.c

mod_proxy_uwsgi has a issue to use a default port of uwsgi:// scheme.
I reported to apache httpd maintainer(*), but not fix yet.

(*)SEE ALSO: https://bz.apache.org/bugzilla/show_bug.cgi?id=64405

This fix was simplify, add a uwsgi default port to pschemes[] array in proxy_util.c.
Formally, this fix should be define UWSGI_SCHEME and UWSGI_DEFAULT_PORT,
but already reported in apache httpd maintainer(*).
Comment 1 Bernard Spil freebsd_committer 2020-11-15 14:44:15 UTC
Hi Nork,

Looks like there isn't something like a default port for uWSGI (at least looking at the uWSGI docs I don't see it). Guess this is why it's not defined in the code. The documentation clearly contains the port for all configurations. Perhaps makes sense to submit patch to add an admonition "NOTE: You must use a port number in your ProxyPass"  instead?

Cheers, Bernard.