Bug 250958 - Update devel/valgrind-devel
Summary: Update devel/valgrind-devel
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: amd64 Any
: --- Affects Many People
Assignee: Yuri Victorovich
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2020-11-08 16:17 UTC by Paul Floyd
Modified: 2021-03-14 03:19 UTC (History)
3 users (show)

See Also:


Attachments
Updated ports files (20.50 KB, application/x-tar)
2020-11-08 16:17 UTC, Paul Floyd
no flags Details
Another update (20.00 KB, application/x-tar)
2021-02-19 14:58 UTC, Paul Floyd
no flags Details
updated.patch (45.93 KB, patch)
2021-03-14 02:30 UTC, Yuri Victorovich
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Paul Floyd 2020-11-08 16:17:15 UTC
Created attachment 219464 [details]
Updated ports files

Some minor fixes and one significant one for FreeBSD 12.2

Not certain that I did all of this correctly:

1. Got the GH_TAGNAME from git describe (I suppose that the same on the github web page would also do)

2. Manual edits to Makefile for the version number

3. Manual edits to pkg-descr

4. Ran make makesum

5. Ran make makeplist > pkg-plist

pkg-plist seems to be much changed, not sure if that was right.


Ran a few tests like make, make package, make install, portlint -v
Comment 1 Paul Floyd 2021-02-19 14:58:31 UTC
Created attachment 222639 [details]
Another update

Adds 14.0-CURRENT
Hack for RW LOAD segemnts with clang 10 (12.2 and later)
Comment 2 Yuri Victorovich freebsd_committer 2021-03-14 02:28:51 UTC
Current valgrind-3.10.1.20160113_8,1 breaks on 12.2 amd64:

> $ valgrind /bin/ls
> valgrind: mmap(0x200000, 45056) failed in UME with error 22 (Invalid argument).
> valgrind: this can be caused by executables with very large text, data or bss segments.


The version from this bug works.
Comment 3 Yuri Victorovich freebsd_committer 2021-03-14 02:30:13 UTC
Created attachment 223248 [details]
updated.patch
Comment 4 Yuri Victorovich freebsd_committer 2021-03-14 03:19:29 UTC
Committed, thanks!

Yuri
Comment 5 commit-hook freebsd_committer 2021-03-14 03:19:56 UTC
A commit references this bug:

Author: yuri
Date: Sun Mar 14 03:19:30 UTC 2021
New revision: 568304
URL: https://svnweb.freebsd.org/changeset/ports/568304

Log:
  devel/valgrind-devel: Update 3.17.0.g20200723 -> 3.17.0.g20210219

  PR:		250958
  Submitted by:	pjfloyd@wanadoo.fr (maintainer)

Changes:
  head/devel/valgrind-devel/Makefile
  head/devel/valgrind-devel/distinfo
  head/devel/valgrind-devel/pkg-descr
  head/devel/valgrind-devel/pkg-plist