Bug 251122 - devel/jenkins, devel/jenkins-lts cannot install plugins
Summary: devel/jenkins, devel/jenkins-lts cannot install plugins
Status: Closed Unable to Reproduce
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Many People
Assignee: Li-Wen Hsu
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2020-11-14 01:58 UTC by Gary
Modified: 2021-06-20 03:34 UTC (History)
5 users (show)

See Also:


Attachments
Jenkins log file (368.42 KB, text/plain)
2020-11-14 01:58 UTC, Gary
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Gary 2020-11-14 01:58:31 UTC
Created attachment 219664 [details]
Jenkins log file

Jenkins seems to be shipping with an old address somewhere for getting plugins.

I saw the same issue on another, previously working Linux server as well. After updating Jenkins itself, the instance on the Linux server started working again. The latest version in the FreeBSD repo doesn't work.

The FreeBSD instance is a fresh installation.

The Jenkins log has many exceptions like this:

java.io.IOException: Server returned HTTP response code: 503 for URL: https://get.jenkins.io/plugins/workflow-scm-step/2.11/workflow-scm-step.hpi
Comment 1 Brad Davis freebsd_committer 2021-02-11 16:44:12 UTC
What version of Jenkins and FreeBSD?  It works for me..
Comment 2 Gary 2021-02-12 05:46:57 UTC
Yeah, it started working again some time ago. I assumed there was an update to the FreeBSD Jenkins package, but maybe a server was down.

Thanks.
Comment 3 Li-Wen Hsu freebsd_committer 2021-06-20 03:34:32 UTC
Sorry that I'm unable to reproduce this, please reopen if it happens again. Thanks for the report.