Bug 251144 - net/routinator: inconsistent tal-dir suggestions in sample config vs rc script
Summary: net/routinator: inconsistent tal-dir suggestions in sample config vs rc script
Status: Closed DUPLICATE of bug 251732
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: Jason E. Hale
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2020-11-14 23:08 UTC by C
Modified: 2021-01-22 12:28 UTC (History)
2 users (show)

See Also:
bugzilla: maintainer-feedback? (jaap)


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description C 2020-11-14 23:08:47 UTC
The content in:

/usr/local/etc/routinator/routinator.conf.system-service

suggests that the tal directory should go to:
tal-dir = "/var/lib/routinator/tals"

but after renaming 
/usr/local/etc/routinator/routinator.conf.system-service
to
/usr/local/etc/routinator/routinator.conf

and preparing the tals directory, routinator refuses to start with the following message:
Need to initialize routinator with tals, see man routinator

This is because the rc.d script ignores what the config says and checks another directory: /var/routinator/tals


[...]
: ${wrkdir:="/var/routinator"}

pidfile=${wrkdir}/${name}.pid
routinator_config=${routinator_conf:-"/usr/local/etc/routinator/routinator.conf"}
required_file=${routinator_config}
command_args="-c ${routinator_config} --rsync-command=/usr/local/bin/rsync server -d --user routinator --group routinator --pid-file=${pidfile} --working-dir=${wrkdir}"

check_init() {
	if [ ! -d ${wrkdir}/tals ]; then
		echo
		echo -n "Need to initialize routinator with tals, "
		echo "see man routinator"
		echo
		exit 1
	fi
}



So I suggest to change the sample config paths for consistency:
repository-dir = "/var/routinator/rpki-cache"
tal-dir = "/var/routinator/tals"
Comment 1 Jason E. Hale freebsd_committer 2021-01-22 12:25:18 UTC
This appears to be addressed in bug #251732.

*** This bug has been marked as a duplicate of bug 251732 ***
Comment 2 commit-hook freebsd_committer 2021-01-22 12:28:16 UTC
A commit references this bug:

Author: jhale
Date: Fri Jan 22 12:28:06 UTC 2021
New revision: 562299
URL: https://svnweb.freebsd.org/changeset/ports/562299

Log:
  net/routinator: Update to 0.8.2 [1]

  Fix repository initialization. [2]

  PR:		251732 [1], 251144 [2]
  Submitted by:	Jaap Akkerhuis <jaap@NLnetLabs.nl> (maintainer) [1]
  Reported by:	C <cm@appliedprivacy.net> [2]

Changes:
  head/net/routinator/Makefile
  head/net/routinator/distinfo
  head/net/routinator/files/patch-etc_routinator.conf.example
  head/net/routinator/files/pkg-message.in
  head/net/routinator/files/routinator.in
  head/net/routinator/pkg-plist