Bug 251145 - cad/freecad: fix build with Python 3.9
Summary: cad/freecad: fix build with Python 3.9
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: Christoph Moench-Tegeder
URL: https://github.com/FreeCAD/FreeCAD/co...
Keywords:
Depends on:
Blocks:
 
Reported: 2020-11-14 23:56 UTC by Oleg Sidorkin
Modified: 2020-12-13 22:27 UTC (History)
1 user (show)

See Also:
bugzilla: maintainer-feedback? (cmt)


Attachments
https://github.com/FreeCAD/FreeCAD/commit/ae641dc5278efafa22b168fc196875558b92e436 applied to 18.4 (9.63 KB, patch)
2020-11-14 23:56 UTC, Oleg Sidorkin
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Oleg Sidorkin 2020-11-14 23:56:56 UTC
Created attachment 219693 [details]
https://github.com/FreeCAD/FreeCAD/commit/ae641dc5278efafa22b168fc196875558b92e436 applied to 18.4

tp_print field is gone
Comment 1 Oleg Sidorkin 2020-11-29 07:57:13 UTC
FreeCad was updated to the 18.5 version that has this patch
Comment 2 Christoph Moench-Tegeder freebsd_committer 2020-11-30 11:03:45 UTC
As far as I can see, the patch is not in 0.18.5 - all we have is the addon manager fix, some C++ fixes and some really supposedly minor stuff (color matching, reorderings... the swig-files haven't been touched at all. Did you actually test 0.18.5 with Python 3.9? I haven't come around to that (lack of time , etc.).
Comment 3 Oleg Sidorkin 2020-11-30 13:26:35 UTC
(In reply to Christoph Moench-Tegeder from comment #2)
Freecad updated to 0.18.5 ok.
However I've forgot to remove my patches (my bad). So yes, the problem is still here
Comment 4 Christoph Moench-Tegeder freebsd_committer 2020-12-13 22:24:59 UTC
I took a slightly different approach and kept the patch as one part - that way it's easier to remove it later (one we have 0.19).
Comment 5 commit-hook freebsd_committer 2020-12-13 22:27:53 UTC
A commit references this bug:

Author: cmt
Date: Sun Dec 13 22:24:13 UTC 2020
New revision: 558063
URL: https://svnweb.freebsd.org/changeset/ports/558063

Log:
  try to make FreeCAD compile with Python 3.9

  patch from upstream cannot be applied directly as dos2unix runs
  before patch.

  PR:		251145
  Submitted by:	 Oleg Sidorkin

Changes:
  head/cad/freecad/Makefile
  head/cad/freecad/distinfo
  head/cad/freecad/files/ae641dc5278efaf.patch