Bug 251195 - [patch] Added wording to the handbook ports chapter about using ports in conjunction with pkg
Summary: [patch] Added wording to the handbook ports chapter about using ports in conj...
Status: Closed FIXED
Alias: None
Product: Documentation
Classification: Unclassified
Component: Documentation (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Some People
Assignee: Mateusz Piotrowski
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2020-11-16 23:20 UTC by Fred
Modified: 2020-11-19 05:30 UTC (History)
1 user (show)

See Also:


Attachments
svn diff of en_US.ISO8859-1/handbook/ports/chapter.xml (2.26 KB, patch)
2020-11-16 23:20 UTC, Fred
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Fred 2020-11-16 23:20:37 UTC
Created attachment 219747 [details]
svn diff of en_US.ISO8859-1/handbook/ports/chapter.xml

I added some wording, to the ports section of the handbook, which makes users aware of the issues of using ports in conjunction with pkg. The igor tool reported only one problem. The problem is related to a contraction, but it's on a line which wasn't edited and is not part of the svn-diff. Please consider the diff and if you think the added explanation is appropriate and accurate please commit it.
Comment 1 commit-hook freebsd_committer 2020-11-18 10:33:18 UTC
A commit references this bug:

Author: 0mp
Date: Wed Nov 18 10:32:33 UTC 2020
New revision: 54691
URL: https://svnweb.freebsd.org/changeset/doc/54691

Log:
  Add a warning regarding mixing ports(7) and pkg(8) to install software

  I think it's something that has been missing from the handbook for a long
  time.

  Unfortunately, this patch does not explain all the subtleties of the ports
  framework (like, e.g., that ports create packages during the build process
  which are then installed via pkg). We should probably hint the reader about
  it somewhere, but that's something for another patch. What's important here
  is to warn new users about problems they might encounter.

  Also, add some examples of working with quarterly with Subversion.

  PR:		251195
  Submitted by:	Fred <fjs.usa01 gmail.com>

Changes:
  head/en_US.ISO8859-1/books/handbook/ports/chapter.xml
Comment 2 Mateusz Piotrowski freebsd_committer 2020-11-18 10:39:36 UTC
Thanks, I committed the patch with a couple of changes.
Comment 3 Fred 2020-11-18 17:06:37 UTC
Thanks for reviewing and committing the patch. I see that you wrapped the new paragraph/wording in a Warning, that was a good idea.

"Also, add some examples of working with quarterly with Subversion."

I gave an example under "Procedure 4.2 Subversion Method".
Item 5 is an example of switching to a quarterly branch.
Comment 4 Mateusz Piotrowski freebsd_committer 2020-11-19 05:30:46 UTC
(In reply to Fred from comment #3)
Oh, this "Also" was supposed to mention things that has been done already :) Sorry for the confusion.