Bug 251331 - devel/py-isort: update to 5.6.4
Summary: devel/py-isort: update to 5.6.4
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: Po-Chuan Hsieh
URL:
Keywords: buildisok
: 249286 (view as bug list)
Depends on:
Blocks:
 
Reported: 2020-11-23 16:40 UTC by Dmitry Marakasov
Modified: 2020-12-10 22:09 UTC (History)
0 users

See Also:
bugzilla: maintainer-feedback? (sunpoet)


Attachments
Patch (1.78 KB, patch)
2020-11-23 16:40 UTC, Dmitry Marakasov
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Dmitry Marakasov freebsd_committer 2020-11-23 16:40:00 UTC
Created attachment 219907 [details]
Patch

- python2 related depends are no longer needed since only python >=3.6 is supported
- tests are removed since pypi distribution does not contain tests (may consider switching to fetching sources from GH to fix this)
Comment 1 Po-Chuan Hsieh freebsd_committer 2020-11-24 19:17:06 UTC
As I said in bug #249286 comment 1, the update is planned (and deferred) because isort 5+ requires python 3.6+.
That means the patch is incomplete since the patch for dependent ports is missing.
Comment 2 Po-Chuan Hsieh freebsd_committer 2020-11-24 19:17:11 UTC
*** Bug 249286 has been marked as a duplicate of this bug. ***
Comment 3 Po-Chuan Hsieh freebsd_committer 2020-11-24 19:18:40 UTC
(In reply to Sunpoet Po-Chuan Hsieh from comment #1)

I'll check the dependent ports this weekend.
Comment 4 Automation User 2020-12-09 03:34:48 UTC
Build and package info is available at https://gitlab.com/swills/freebsd-ports/pipelines/227061110
Comment 5 Dmitry Marakasov freebsd_committer 2020-12-10 17:20:37 UTC
> That means the patch is incomplete since the patch for dependent ports is missing

What's exactly missing? Limiting dependent ports USES=python: version?

> I'll check the dependent ports this weekend

Ping.
Comment 6 commit-hook freebsd_committer 2020-12-10 22:00:52 UTC
A commit references this bug:

Author: sunpoet
Date: Thu Dec 10 21:59:53 UTC 2020
New revision: 557686
URL: https://svnweb.freebsd.org/changeset/ports/557686

Log:
  Update to 5.6.4

  - Update WWW

  Changes:	https://github.com/PyCQA/isort/releases
  PR:		251331
  Submitted by:	amdmi3

Changes:
  head/devel/py-isort/Makefile
  head/devel/py-isort/distinfo
  head/devel/py-isort/pkg-descr
Comment 7 Po-Chuan Hsieh freebsd_committer 2020-12-10 22:09:25 UTC
(In reply to Dmitry Marakasov from comment #5)

> What's exactly missing? Limiting dependent ports USES=python: version?

Yes, it was done in r557687. devel/py-factory-boy and sysutils/py-hcloud need this change to drop python 2.7 flavor.
Comment 8 Po-Chuan Hsieh freebsd_committer 2020-12-10 22:09:44 UTC
Committed. Thanks!