Bug 251337 - lang/rust returns SIGSEGV building on arm64
Summary: lang/rust returns SIGSEGV building on arm64
Status: Closed DUPLICATE of bug 251254
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: arm64 Any
: --- Affects Some People
Assignee: FreeBSD Rust Team
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2020-11-23 22:13 UTC by Dan Kotowski
Modified: 2021-01-02 14:18 UTC (History)
2 users (show)

See Also:
bugzilla: maintainer-feedback? (rust)


Attachments
rust v1.48 poudrere armv8 failure log (169.66 KB, text/plain)
2021-01-02 14:18 UTC, Dave Cottlehuber
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Dan Kotowski 2020-11-23 22:13:40 UTC
When building lang/rust for 13.0 on arm64, we get SIGSEGV:

FreeBSD 13.0-CURRENT r367710
+D20835,D20974,D21017,D24423,D27306



=====BEGIN CONSOLE=====
c Assemble { target_compiler: Compiler { stage: 1, host: TargetSelection { triple: "aarch64-unknown-freebsd", file: None } } }
> Cargo { compiler: Compiler { stage: 1, host: TargetSelection { triple: "aarch64-unknown-freebsd", file: None } }, target: TargetSelection { triple: "aarch64-unknown-freebsd", file: None } }
  > ToolBuild { compiler: Compiler { stage: 1, host: TargetSelection { triple: "aarch64-unknown-freebsd", file: None } }, target: TargetSelection { triple: "aarch64-unknown-freebsd", file: None }, tool: "cargo", path: "src/tools/cargo", mode: ToolRustc, is_optional_tool: false, source_type: Submodule, extra_features: [] }
    > Rustc { target: TargetSelection { triple: "aarch64-unknown-freebsd", file: None }, compiler: Compiler { stage: 1, host: TargetSelection { triple: "aarch64-unknown-freebsd", file: None } } }
      c Std { target: TargetSelection { triple: "aarch64-unknown-freebsd", file: None }, compiler: Compiler { stage: 1, host: TargetSelection { triple: "aarch64-unknown-freebsd", file: None } } }
      c Assemble { target_compiler: Compiler { stage: 1, host: TargetSelection { triple: "aarch64-unknown-freebsd", file: None } } }
      c Assemble { target_compiler: Compiler { stage: 1, host: TargetSelection { triple: "aarch64-unknown-freebsd", file: None } } }
      c Std { target: TargetSelection { triple: "aarch64-unknown-freebsd", file: None }, compiler: Compiler { stage: 1, host: TargetSelection { triple: "aarch64-unknown-freebsd", file: None } } }
      c Sysroot { compiler: Compiler { stage: 1, host: TargetSelection { triple: "aarch64-unknown-freebsd", file: None } } }
      c Sysroot { compiler: Compiler { stage: 1, host: TargetSelection { triple: "aarch64-unknown-freebsd", file: None } } }
      c Sysroot { compiler: Compiler { stage: 1, host: TargetSelection { triple: "aarch64-unknown-freebsd", file: None } } }
      c Sysroot { compiler: Compiler { stage: 1, host: TargetSelection { triple: "aarch64-unknown-freebsd", file: None } } }
      c Sysroot { compiler: Compiler { stage: 1, host: TargetSelection { triple: "aarch64-unknown-freebsd", file: None } } }
      c Llvm { target: TargetSelection { triple: "aarch64-unknown-freebsd", file: None } }
Building stage1 compiler artifacts (aarch64-unknown-freebsd -> aarch64-unknown-freebsd)
running: "/usr/ports/lang/rust/work/bootstrap/bin/cargo" "build" "--target" "aarch64-unknown-freebsd" "-Zbinary-dep-depinfo" "-j" "16" "-v" "--release" "--frozen" "--features" " llvm" "--manifest-path" "/usr/ports/lang/rust/work/rustc-1.47.0-src/src/rustc/Cargo.toml" "--message-format" "json-render-diagnostics"
   Compiling cfg-if v0.1.10
   Compiling libc v0.2.74
   Compiling autocfg v1.0.0
   Compiling lazy_static v1.4.0
   Compiling proc-macro2 v1.0.19
   Compiling scopeguard v1.1.0
command did not execute successfully: "/usr/ports/lang/rust/work/bootstrap/bin/cargo" "build" "--target" "aarch64-unknown-freebsd" "-Zbinary-dep-depinfo" "-j" "16" "-v" "--release" "--frozen" "--features" " llvm" "--manifest-path" "/usr/ports/lang/rust/work/rustc-1.47.0-src/src/rustc/Cargo.toml" "--message-format" "json-render-diagnostics"
expected success, got: signal: 11
Traceback (most recent call last):
  File "x.py", line 11, in <module>
    bootstrap.main()
  File "/usr/ports/lang/rust/work/rustc-1.47.0-src/src/bootstrap/bootstrap.py", line 1009, in main
    bootstrap(help_triggered)
  File "/usr/ports/lang/rust/work/rustc-1.47.0-src/src/bootstrap/bootstrap.py", line 995, in bootstrap
    run(args, env=env, verbose=build.verbose)
  File "/usr/ports/lang/rust/work/rustc-1.47.0-src/src/bootstrap/bootstrap.py", line 143, in run
    raise RuntimeError(err)
RuntimeError: failed to run: /usr/ports/lang/rust/work/rustc-1.47.0-src/build/bootstrap/debug/bootstrap build --jobs=16
*** Error code 1

Stop.
make[1]: stopped in /usr/ports/lang/rust
*** Error code 1

Stop.
make: stopped in /usr/ports/lang/rust
=====END CONSOLE=====
Comment 1 Mikael Urankar freebsd_committer 2020-11-24 09:16:37 UTC

*** This bug has been marked as a duplicate of bug 251254 ***
Comment 2 Dave Cottlehuber freebsd_committer 2021-01-02 14:18:37 UTC
Created attachment 221194 [details]
rust v1.48 poudrere armv8 failure log