Bug 251360 - irc/irssi: Properly document out of the box regression of Perl support
Summary: irc/irssi: Properly document out of the box regression of Perl support
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: freebsd-ports-bugs (Nobody)
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2020-11-25 00:52 UTC by daniel.engberg.lists
Modified: 2020-11-26 08:08 UTC (History)
3 users (show)

See Also:
dor.bsd: maintainer-feedback+


Attachments
Patch for irssi (395 bytes, patch)
2020-11-25 00:52 UTC, daniel.engberg.lists
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description daniel.engberg.lists 2020-11-25 00:52:39 UTC
Created attachment 219947 [details]
Patch for irssi

Perl support is optional so the pkg-message should reflect on that fact and while at it switch to UCL format.
Comment 1 Fernando Apesteguía freebsd_committer 2020-11-25 11:33:04 UTC
Perl seems to be needed for building since the change to build with mesos.
Comment 2 David O'Rourke 2020-11-25 22:38:25 UTC
This pkg-message looks good to me.

Perl being required for build is being handled over in https://bugs.freebsd.org/bugzilla/show_bug.cgi?id=251371

-David
Comment 3 commit-hook freebsd_committer 2020-11-26 08:02:54 UTC
A commit references this bug:

Author: fernape
Date: Thu Nov 26 08:02:38 UTC 2020
New revision: 556320
URL: https://svnweb.freebsd.org/changeset/ports/556320

Log:
  irc/irssi: Unbreak when PERL=OFF

  In r556069 the port changed to build with meson. This requires perl to build
  regardles of the option PERL that allows perl scripts to be run in irssi.

  While here clarify pkg-message (sent by daniel.engberg.lists@pyret.net)

  PR:	251371 251360
  Submitted by:	dor.bsd@xm0.uk (maintainer)
  Reported by:	m.bueker@berlin.de

Changes:
  head/irc/irssi/Makefile
  head/irc/irssi/pkg-message
Comment 4 Fernando Apesteguía freebsd_committer 2020-11-26 08:08:10 UTC
Committed,

Thanks!