Bug 251378 - net-mgmt/unifi6: Update to 6.0.36
Summary: net-mgmt/unifi6: Update to 6.0.36
Status: Closed Overcome By Events
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: freebsd-ports-bugs (Nobody)
URL: https://community.ui.com/releases/Uni...
Keywords:
Depends on:
Blocks:
 
Reported: 2020-11-25 14:43 UTC by Juraj Lutter
Modified: 2020-12-03 18:32 UTC (History)
2 users (show)

See Also:


Attachments
net-mgmt/unifi6: Update to 6.0.36 (3.33 KB, patch)
2020-11-25 14:43 UTC, Juraj Lutter
otis: maintainer-approval+
Details | Diff
net-mgmt/unifi6: Update to 6.0.36 (3.37 KB, patch)
2020-12-03 10:49 UTC, Juraj Lutter
otis: maintainer-approval+
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Juraj Lutter freebsd_committer 2020-11-25 14:43:33 UTC
Created attachment 219964 [details]
net-mgmt/unifi6: Update to 6.0.36

Hi,

please find the patch attached.

* Improvements:
  - Add info and link to DHCP Relay in Network form.
  - Add U6 device images.
  - Add event handling for missing DHCP Relay Server.
  - SSID byte length validation changed from 31 to 32.
  - Improve the request to resolve fingerprint icon in Beta Clients page.
  - Beta Settings - SSH section validation improvements.
  - Free package trial rule updates.
  - Enable New Settings & Clients pages by default.

* Bugfixes:
  - Fix peak client count being sometimes shown lower than current client
    count.
  - Fix not being able to click Next button in Schedule Upgrade form.
  - Fix being unable to save device SSH password, Allow hyphens in form
    validation of hostname.
  - Fix a runtime error in new dashboard caused by unrecognised browsers timezone.
  - Fix DPI App restrictions not getting applied when saved from New Settings.
  - Fix form validation in New Settings for cases when hostname includes
    hyphens.
  - Fix screen becoming blank when clicking "cancel" during AP edit or create.
  - Fix Network Controller crashing the UniFi OS Portal upon quick navigation.
  - Fix DHCP Relay link in network form.
  - Fix Settings - Security - internet threat management page not opening on
    UCK.
  - Fix users being unable to save Threat Management changes.
  - Fix empty SSID from backup breaking WiFi form.
  - Fix error occurring in network table parsing when disconnecting devices.
  - Remove custom upgrade option for UDM.
  - Remove endpoint scan from Clients.
  - Allow to disable RADIUS without password.
  - Table UX (width) fixes in Clients page.
  - Use correct placeholder for UDM commit error notifications.
  - VLAN settings are not provisioned for Wireless Uplink on UDM-Base.
  - Don't count UAP's BSSIDs as clients.
  - Enable Auto Scale Network for default network created during setup.
  - Disable SSID action buttons upon initial click while controller is
    processing the request.
  - Resolve the 'Module "base-unifi" is not available!' error that appears when
    trying to load UniFi Network controller from the Remote Management Service.
  - Ensure the correct content placeholder appears in Dashboard in place of
    WiFi Experience chart, if user has no APs adopted.
  - Show a placeholder if users have no APs adopted.
  - IAPP Key is not provisioned.
  - Allow deleting WAN2 after restoring UDM-Pro backup on USG setup.
  - Rectify the list of devices shown as unsupported for certain features.
  - Close the survey modal 2 seconds after it has been submitted.
  - WiFiman topology adjustments.
  - Handle unsuccessful page loads in WiFiman page by displaying a Toast.


Tesport on 11.4, 12.1, 12.1 OK.
Comment 1 Rainer Hurling freebsd_committer 2020-11-27 11:24:05 UTC
Hi Juraj,

Thanks for the update.

Just to be sure: Maintainer of the port is Vlad Galu <dev@dudu.ro>, is the maintainer approval ('+') from him?

I would like to change the URL in pkg-descr into
  https://help.ui.com/hc/en-us/categories/200320654-UniFi-Wireless
Do you agree?
Comment 2 Rainer Hurling freebsd_committer 2020-11-27 11:52:31 UTC
(In reply to Rainer Hurling from comment #1)

Sorry for the question with the maintainer approval. I looked in the wrong port: Of course you are the maintainer of net-mgmt/unifi6 ;)
Comment 3 Juraj Lutter freebsd_committer 2020-11-27 16:20:04 UTC
(In reply to Rainer Hurling from comment #1)

I was worried a bit that I missed something :-)
Yes, you can change the WWW line in pkg-descr (although the present one just redirects to the proposed one).
Comment 4 Rainer Hurling freebsd_committer 2020-11-27 17:28:22 UTC
(In reply to Juraj Lutter from comment #3)

The https URL has at least two advantages: Using a secure connection and saving on forwarding ;)


One more question: Is there any reason to use EXTRACT_CMD=/usr/bin/ar instead of EXTRACT_CMD=${AR}, which uses /usr/local/bin/ar from devel/binutils?

I tested with amd64 and it seems to extract like expected. Is there something wrong with it for other platforms?
Comment 5 Juraj Lutter freebsd_committer 2020-12-03 10:49:49 UTC
Created attachment 220213 [details]
net-mgmt/unifi6: Update to 6.0.36

Update to 6.0.36 and silenced portlint.
Comment 6 Juraj Lutter freebsd_committer 2020-12-03 11:07:20 UTC
(In reply to Rainer Hurling from comment #4)
- /usr/bin/ar has been replaced by ${AR} and USE_BINUTILS=yes
- As I don't have an access to FreeBSD build cluster, things are a bit complicated (can be tested in qemu but, for example, OpenJDK build in qemu for aarch64 would take ages in my setup). I might give it a try sometimes overnight.
Comment 7 Rainer Hurling freebsd_committer 2020-12-03 12:47:28 UTC
(In reply to Juraj Lutter from comment #6)

Hi Juraj,
Thanks for the updated patch. Unfortunately, is does not build on Poudriere and gives the following type of error:

=======================<phase: extract        >============================
===>   unifi6-6.0.36 depends on file: /usr/local/sbin/pkg - found
===> Fetching all distfiles required by unifi6-6.0.36 for building
===>  Extracting for unifi6-6.0.36
=> SHA256 Checksum OK for unifi6-6.0.36/unifi_sysvinit_all.deb.
=> SHA256 Checksum OK for unifi6-6.0.36/javax.activation-api-1.2.0.jar.
/bin/sh: /usr/local/bin/ar: not found
cp -f /portdistfiles/unifi6-6.0.36/javax.activation-api-1.2.0.jar  /wrkdirs/usr/ports/net-mgmt/unifi6/work/unifi6-6.0.36/usr/lib/unifi/lib/
cp: directory /wrkdirs/usr/ports/net-mgmt/unifi6/work/unifi6-6.0.36/usr/lib/unifi/lib does not exist
*** Error code 1


It turns out, that USE_BINUTILS=yes is the culprit. This line is not needed at all (NO_BUILD=yes) and seems to irritate in finding the correct ar binary.

A good example for a working ${AR} is in comms/iwmbt-firmware, also with NO_BUILD=yes.


If you agree, I will remove the line with USE_BINUTILS=yes from the Makefile. A new patch from your side is not needed.


BTW: The port is _not_ 'buildable' at the moment for i386, because databases/mongodb36, one its RUN_DEPENDS is 'ONLY_FOR_ARCHS=aarch64 amd64'.
Comment 8 Juraj Lutter freebsd_committer 2020-12-03 13:15:11 UTC
(In reply to Rainer Hurling from comment #7)
- Then also this port should be marked for amd64 and aarch64 only (to correspond with mongodb36), right?

- I've added USE_BINUTILS tentatively. But you are right, it is not needed. It built for me, because I already had binutils installed (now make -V AR showed that it's not needed).

Thank you for mentoring.
Comment 9 Peter Libassi 2020-12-03 16:00:28 UTC
6.0.41 is out now.
Comment 10 Juraj Lutter freebsd_committer 2020-12-03 16:07:18 UTC
As 6.0.41 is out, I'm closing this and will submit a new PR.
Comment 11 Juraj Lutter freebsd_committer 2020-12-03 16:28:38 UTC
bug #251565 has been opened. I wonder whether it will make it before next version.
Comment 12 Peter Libassi 2020-12-03 18:32:57 UTC
I installed succesfully 6.0.36 with this patch on 12.2/amd64